#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?!\d\d?[ex]\d\d?)(?:\[(?:[-\w\s]+)*\] )?(.*?)[-_. ]?(?:[\{\(\[]?(?:dvdrip|[-._\b]ita|[-._\b]eng|xvid| cd\d|dvdscr|\w{1,5}rip|divx|\d+p|\d{4}).*?)?\.([\w]{2,3})$"
Local $sString = "22. Non Puoi Sempre Dire Quello Kent Ti Pare.avi" & @CRLF & _
"6x13 - Una festa spettacolare.mkv" & @CRLF & _
"After earth.avi" & @CRLF & _
"Capitan America Il Primo Vendicatore 480p.mkv" & @CRLF & _
"Dylan Dog 2010 Ac3.avi" & @CRLF & _
"FUMETTOLOGY - 11 - PUNTATA SPECIALE.by.IperB.mkv" & @CRLF & _
"Guida galattica per autostoppisti [BDrip 720p ITA-ENG sub ITA-ENG].mkv" & @CRLF & _
"Hook - Capitan Uncino (1991).avi" & @CRLF & _
"Kick Ass 2.avi" & @CRLF & _
"Lemony Snicket - Una serie di sfortunati eventi 2004.avi" & @CRLF & _
"Monty Python e il Sacro Graal.avi" & @CRLF & _
"Pacific_Rim_2004_BdRip_1080p_ITA_ENG_ANONIMO_CREW.mkv" & @CRLF & _
"Pompeii.2014.iTALiAN.DTS.Dual.1080p.BluRay.x264-TRtD_TeaM.mkv" & @CRLF & _
"Ralph Spaccatutto.avi" & @CRLF & _
"Red Hot Chili Simpson.avi" & @CRLF & _
"RobinHood-UnUomoInCalzamaglia.ENG.srt" & @CRLF & _
"The.Lego.Movie.2014.iTALiAN.AC3.DUAL.1080p.BluRay.x264-TrTd_TeaM.mkv" & @CRLF & _
"The.Pagemaster.1994.1080p.BluRyMux.by.gemini9669.mkv" & @CRLF & _
"Tom.&.Jerry.Avventure.Giganti.Giant.Adventure.2013.DVDRip.ITA.AC3.ENG.Mp3-MLN.avi" & @CRLF & _
"Tron 480p.mkv" & @CRLF & _
"Viaggi Spazio - Temporali.avi" & @CRLF & _
"Vite Aliene.avi" & @CRLF & _
"[DivX - ITA] The Simpson - Natale con i Simpsons 2003.avi" & @CRLF & _
"[SUB ITA] Monty Python e il Sacro Graal.srt" & @CRLF & _
"[Sub ENG] Monty Python e il Sacro Graal.srt" & @CRLF & _
"codeschool_1322.mp4" & @CRLF & _
"corto.avi" & @CRLF & _
"film xvid.ENG.srt" & @CRLF & _
"[rec].mp4" & @CRLF & _
"recita.mp4" & @CRLF & _
"regeng.flv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")