use strict;
my $str = '[content]
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec tortor quam, gravida at nibh nec, vestibulum commodo felis. Cras eu ornare massa. Vivamus porta laoreet ullamcorper. Fusce metus ipsum, cursus ut fringilla ac, vulputate in orci. Nulla ultrices porttitor porttitor. Sed consectetur vel velit non sodales. Vivamus mi eros, facilisis et nulla sed, convallis lacinia orci. Morbi nec neque pulvinar tortor porttitor tincidunt. Praesent imperdiet finibus arcu, ac interdum lacus finibus eu. Duis et ante in tellus pulvinar elementum blandit nec mauris. Suspendisse eu lobortis nunc, ut volutpat metus.
Proin eu ligula cursus nibh tincidunt laoreet. Aliquam vel luctus metus, at feugiat lacus. Nullam rutrum eros ac nisl efficitur faucibus. Nullam tincidunt libero laoreet fringilla cursus. Curabitur ut fringilla nunc. Integer eget elementum lacus. Fusce mollis, sapien vitae euismod mattis, nisl tellus euismod nisi, in facilisis mi neque et urna. Maecenas sit amet metus blandit, volutpat ipsum sed, scelerisque tortor. Cras molestie euismod tellus, id bibendum enim ullamcorper id. Duis maximus augue orci, et congue ipsum consequat in. Maecenas auctor neque lectus, vitae lobortis lectus dapibus vel. Sed quis leo at odio pharetra sagittis maximus a massa. Nullam luctus rhoncus blandit.
Aenean ullamcorper nec augue quis hendrerit. In quis feugiat libero. In nec auctor ante. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Duis eget metus quis ex cursus blandit quis vel enim. Aliquam erat volutpat. Integer pharetra, nunc sed aliquam suscipit, urna sem vulputate felis, et efficitur dolor eros sed eros. Mauris eleifend orci eu ultricies cursus. Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Integer efficitur magna lectus.
Morbi feugiat odio a ante dapibus, id pulvinar ex eleifend. Duis lobortis nibh non odio tincidunt convallis. Quisque ultrices et magna eget pretium. Pellentesque tempus sit amet magna quis rhoncus. Aenean a aliquet elit, ac placerat metus. Interdum et malesuada fames ac ante ipsum primis in faucibus. Curabitur pulvinar, urna et vehicula feugiat, augue quam mollis ipsum, eget sodales magna nisi facilisis lectus. Suspendisse fringilla ante nibh, et rhoncus est feugiat sed. Cras ut nisi ipsum. Cras auctor diam ut mi ultricies tincidunt. Fusce imperdiet scelerisque ligula vitae luctus. Pellentesque sodales ante quis ipsum viverra finibus.
Pellentesque gravida efficitur neque. Curabitur nec nunc hendrerit nunc rutrum tincidunt. Donec at nunc ut ante ullamcorper cursus quis sed metus. Fusce viverra massa leo, eget sodales metus feugiat at. Morbi vel pellentesque mi, vestibulum iaculis neque. Quisque ut nisl sagittis, auctor sem at, tristique ipsum. Praesent vitae ante ut est tincidunt tincidunt non volutpat justo. Aenean tristique quis lectus ut porttitor.
[/content]';
my $regex = qr/\[content\]([\s\S]*?)\[\/content\]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}