re = /^(Mon|Tue|Wed|Thu|Fri|Sat|Sun), ([0-3][0-9]) (Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec) ([0-9]{4}) ([01][0-9]|2[0-3])(:[0-5][0-9]){2} GMT$/
str = 'Sun, 06 Nov 1994 08:49:37 GMT
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end