using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"s;^[^?R*]";
string input = @"z R o 2 R";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}