import Foundation
let pattern = ##"""
# match a body pattern alone on a line
^\g<body>$
# we'll use (?<name>...){0} to define the pattern \g<name>
# without having to match the pattern at the current position
# a body pattern matches
(?<body>
# a sequence of
(?: [^\[\]{}()\n] # non-delimiters
| \g<parens> # parenthesized pattern
| \g<square_brackets> # bracketed pattern
| \g<curly_braces> # braced pattern
)*
){0}
# a parenthesized pattern matches
(?<parens>
\( # an open paren
\g<body> # a valid body
\) # a close paren
){0}
# a bracketed pattern matches
(?<square_brackets>
\[ # an open square bracket
\g<body> # a valid body
\] # a close square bracket
){0}
# a braced pattern matches
(?<curly_braces>
\{ # an open curly brace
\g<body> # a valid body
\} # a close curly brace
){0}
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
matches:
a plain string
a string containing (matched parens) [matched brackets] and {matched braces}
nested (parens (within) parens)
nested [parens (within) brackets]
()()[({({[]})[({})]})]
non-matches:
(unbalanced parens
([balanced but misordered)]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)