use strict;
my $str = '<p style="margin-bottom:24px;font-variant-numeric:normal;font-variant-east-asian:normal;font-size:17.6px;line-height:1.44;font-family:NotoSans-Regular;padding:0px;border:0px;vertical-align:baseline;letter-spacing:-0.2px;background-color:rgba(255, 255, 255, 0.95);">Theo tác giả <a href="https://tuoitre.vn/tran-cao-bao-long.html" title="Trần Cao Bảo Long" target="_blank" style="color:#ed1b2f;margin:0px;padding:0px;border:0px;font:inherit;vertical-align:baseline;display:initial;text-decoration-line:none;letter-spacing:-0.2px;">Trần Cao Bảo Long</a>, bộ ảnh "Chợ trên đá" được chọn lọc trong thời gian 20 năm anh theo đuổi đề tài đời sống, phong cảnh, con người của vùng cao nguyên đá ở tỉnh Hà Giang.</p><p style="margin-bottom:24px;font-variant-numeric:normal;font-variant-east-asian:normal;font-size:17.6px;line-height:1.44;font-family:NotoSans-Regular;padding:0px;border:0px;vertical-align:baseline;letter-spacing:-0.2px;background-color:rgba(255, 255, 255, 0.95);">Trong buổi sáng khai mạc, một số bức ảnh đã được bán (khách để lại địa chỉ, ban tổ chức sẽ in ra và giao tận nhà). Hai vợ chồng du khách người Úc đi ngang qua đã đặt mua bức ảnh một phụ nữ gùi rau, hoa bí ra chợ Mèo Vạc. Một số nhiếp ảnh gia, diễn viên, khách mua ủng hộ nhiều cuốn lịch bàn làm quà tặng bạn bè.</p><p style="margin-bottom:24px;font-variant-numeric:normal;font-variant-east-asian:normal;font-size:17.6px;line-height:1.44;font-family:NotoSans-Regular;padding:0px;border:0px;vertical-align:baseline;letter-spacing:-0.2px;background-color:rgba(255, 255, 255, 0.95);">Triển lãm ảnh không ghi chú thích bên ngoài, khách muốn xem nội dung ảnh cần dùng điện thoại thông minh hay máy tính bảng scan, quét mã dưới góc ảnh, sẽ xem được thông tin cũng như câu chuyện của bức ảnh đó. Một cô gái sau khi quét mã đã thích thú chia sẻ với người bạn đi cùng về thông tin cô bé bán gà coi con gà như người bạn, cô nói với tác giả rằng chỉ trao đổi gà lấy vật dụng khác chứ không bán.</p><p style="margin-bottom:24px;font-variant-numeric:normal;font-variant-east-asian:normal;font-size:17.6px;line-height:1.44;font-family:NotoSans-Regular;padding:0px;border:0px;vertical-align:baseline;letter-spacing:-0.2px;background-color:rgba(255, 255, 255, 0.95);">Ảnh, lịch bàn 2023 được bán trong triển lãm cũng như tiền ủng hộ của các nhà hảo tâm trong dịp này sẽ được đóng góp cho việc mua một số trang thiết bị, cơ sở vật chất cho cơ sở lưu trú của Trường Phổ thông dân tộc bán trú TH&THCS Sà Phìn - ngôi trường nằm ở thung lũng xã Sà Phìn, huyện Đồng Văn, Hà Giang, cạnh khu di tích Nhà Vương (Dinh Vua Mèo).</p>';
my $regex = qr/<(?:(?!input)[^>])*>(?:<\/[^>]*>)?/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}