import Foundation
let pattern = ##"(?:[M|m](?:edical|EDICAL|rn|RN|r|R)|[P|p](?:atient|ATIENT))(?:\s+(?:record|Record|RECORD))?(?:\s+(?:id|identification|name|no|number|Id|Identification|Name|No|Number|ID|IDENTIFICATION|NAME|NO|NUMBER))?(?:[\s#]*)?0(?!0{7})\d{7}\b|\b0(?!0{7})\d{7}\s*(?:[M|m](?:edical|EDICAL|r|R|rn|RN)|[P|p](?:atient|ATIENT))(?:\s+(?:record|Record|RECORD))?(?:\s+(?:id|name|no|number|Id|Name|No|Number|ID|NAME|NO|NUMBER))?\b"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
00000000 GIBBERIGH
00000000 Gibberigh
00000000 ME
00000000 MEDICAL
00000000 MEDICAL NUMBER
00000000 MEDICAL RECORD NUMBER
00000000 MR #
00000000 MR#
00000000 MRN
00000000 MRN #
00000000 MRN#
00000000 MRO
00000000 Me
00000000 Medical
00000000 Medical number
00000000 Medical record number
00000000 Mr #
00000000 Mr#
00000000 Mrn
00000000 Mrn #
00000000 Mrn#
00000000 Mro
00000000 PATIENT ID
00000000 PATIENT IDENTIFICATION
00000000 PATIENT NAME
00000000 PATIENT NO
00000000 PATIENT NUMBER
00000000 Patient id
00000000 Patient identification
00000000 Patient name
00000000 Patient no
00000000 Patient number
00000000 gibberigh
00000000 me
00000000 medical
00000000 medical number
00000000 medical record number
00000000 mr #
00000000 mr#
00000000 mrn
00000000 mrn #
00000000 mrn#
00000000 mro
00000000 patient id
00000000 patient identification
00000000 patient name
00000000 patient no
00000000 patient number
00000000GIBBERIGH
00000000Gibberigh
00000000ME
00000000MEDICAL
00000000MEDICAL NUMBER
00000000MEDICAL RECORD NUMBER
00000000MR #
00000000MR#
00000000MRN
00000000MRN #
00000000MRN#
00000000MRO
00000000Me
00000000Medical
00000000Medical number
00000000Medical record number
00000000Mr #
00000000Mr#
00000000Mrn
00000000Mrn #
00000000Mrn#
00000000Mro
00000000PATIENT ID
00000000PATIENT IDENTIFICATION
00000000PATIENT NAME
00000000PATIENT NO
00000000PATIENT NUMBER
00000000Patient id
00000000Patient identification
00000000Patient name
00000000Patient no
00000000Patient number
00000000gibberigh
00000000me
00000000medical
00000000medical number
00000000medical record number
00000000mr #
00000000mr#
00000000mrn
00000000mrn #
00000000mrn#
00000000mro
00000000patient id
00000000patient identification
00000000patient name
00000000patient no
00000000patient number
00012345 GIBBERIGH
00012345 Gibberigh
00012345 ME
00012345 MEDICAL
00012345 MEDICAL NUMBER
00012345 MEDICAL RECORD NUMBER
00012345 MR #
00012345 MR#
00012345 MRN
00012345 MRN #
00012345 MRN#
00012345 MRO
00012345 Me
00012345 Medical
00012345 Medical number
00012345 Medical record number
00012345 Mr #
00012345 Mr#
00012345 Mrn
00012345 Mrn #
00012345 Mrn#
00012345 Mro
00012345 PATIENT ID
00012345 PATIENT IDENTIFICATION
00012345 PATIENT NAME
00012345 PATIENT NO
00012345 PATIENT NUMBER
00012345 Patient id
00012345 Patient identification
00012345 Patient name
00012345 Patient no
00012345 Patient number
00012345 gibberigh
00012345 me
00012345 medical
00012345 medical number
00012345 medical record number
00012345 mr #
00012345 mr#
00012345 mrn
00012345 mrn #
00012345 mrn#
00012345 mro
00012345 patient id
00012345 patient identification
00012345 patient name
00012345 patient no
00012345 patient number
00012345GIBBERIGH
00012345Gibberigh
00012345ME
00012345MEDICAL
00012345MEDICAL NUMBER
00012345MEDICAL RECORD NUMBER
00012345MR #
00012345MR#
00012345MRN
00012345MRN #
00012345MRN#
00012345MRO
00012345Me
00012345Medical
00012345Medical number
00012345Medical record number
00012345Mr #
00012345Mr#
00012345Mrn
00012345Mrn #
00012345Mrn#
00012345Mro
00012345PATIENT ID
00012345PATIENT IDENTIFICATION
00012345PATIENT NAME
00012345PATIENT NO
00012345PATIENT NUMBER
00012345Patient id
00012345Patient identification
00012345Patient name
00012345Patient no
00012345Patient number
00012345gibberigh
00012345me
00012345medical
00012345medical number
00012345medical record number
00012345mr #
00012345mr#
00012345mrn
00012345mrn #
00012345mrn#
00012345mro
00012345patient id
00012345patient identification
00012345patient name
00012345patient no
00012345patient number
00123456 GIBBERIGH
00123456 Gibberigh
00123456 ME
00123456 MEDICAL
00123456 MEDICAL NUMBER
00123456 MEDICAL RECORD NUMBER
00123456 MR #
00123456 MR#
00123456 MRN
00123456 MRN #
00123456 MRN#
00123456 MRO
00123456 Me
00123456 Medical
00123456 Medical number
00123456 Medical record number
00123456 Mr #
00123456 Mr#
00123456 Mrn
00123456 Mrn #
00123456 Mrn#
00123456 Mro
00123456 PATIENT ID
00123456 PATIENT IDENTIFICATION
00123456 PATIENT NAME
00123456 PATIENT NO
00123456 PATIENT NUMBER
00123456 Patient id
00123456 Patient identification
00123456 Patient name
00123456 Patient no
00123456 Patient number
00123456 gibberigh
00123456 me
00123456 medical
00123456 medical number
00123456 medical record number
00123456 mr #
00123456 mr#
00123456 mrn
00123456 mrn #
00123456 mrn#
00123456 mro
00123456 patient id
00123456 patient identification
00123456 patient name
00123456 patient no
00123456 patient number
00123456GIBBERIGH
00123456Gibberigh
00123456ME
00123456MEDICAL
00123456MEDICAL NUMBER
00123456MEDICAL RECORD NUMBER
00123456MR #
00123456MR#
00123456MRN
00123456MRN #
00123456MRN#
00123456MRO
00123456Me
00123456Medical
00123456Medical number
00123456Medical record number
00123456Mr #
00123456Mr#
00123456Mrn
00123456Mrn #
00123456Mrn#
00123456Mro
00123456PATIENT ID
00123456PATIENT IDENTIFICATION
00123456PATIENT NAME
00123456PATIENT NO
00123456PATIENT NUMBER
00123456Patient id
00123456Patient identification
00123456Patient name
00123456Patient no
00123456Patient number
00123456gibberigh
00123456me
00123456medical
00123456medical number
00123456medical record number
00123456mr #
00123456mr#
00123456mrn
00123456mrn #
00123456mrn#
00123456mro
00123456patient id
00123456patient identification
00123456patient name
00123456patient no
00123456patient number
01234567 GIBBERIGH
01234567 Gibberigh
01234567 ME
01234567 MEDICAL
01234567 MEDICAL NUMBER
01234567 MEDICAL RECORD NUMBER
01234567 MR #
01234567 MR#
01234567 MRN
01234567 MRN #
01234567 MRN#
01234567 MRO
01234567 Me
01234567 Medical
01234567 Medical number
01234567 Medical record number
01234567 Mr #
01234567 Mr#
01234567 Mrn
01234567 Mrn #
01234567 Mrn#
01234567 Mro
01234567 PATIENT ID
01234567 PATIENT IDENTIFICATION
01234567 PATIENT NAME
01234567 PATIENT NO
01234567 PATIENT NUMBER
01234567 Patient id
01234567 Patient identification
01234567 Patient name
01234567 Patient no
01234567 Patient number
01234567 gibberigh
01234567 me
01234567 medical
01234567 medical number
01234567 medical record number
01234567 mr #
01234567 mr#
01234567 mrn
01234567 mrn #
01234567 mrn#
01234567 mro
01234567 patient id
01234567 patient identification
01234567 patient name
01234567 patient no
01234567 patient number
01234567GIBBERIGH
01234567Gibberigh
01234567ME
01234567MEDICAL
01234567MEDICAL NUMBER
01234567MEDICAL RECORD NUMBER
01234567MR #
01234567MR#
01234567MRN
01234567MRN #
01234567MRN#
01234567MRO
01234567Me
01234567Medical
01234567Medical number
01234567Medical record number
01234567Mr #
01234567Mr#
01234567Mrn
01234567Mrn #
01234567Mrn#
01234567Mro
01234567PATIENT ID
01234567PATIENT IDENTIFICATION
01234567PATIENT NAME
01234567PATIENT NO
01234567PATIENT NUMBER
01234567Patient id
01234567Patient identification
01234567Patient name
01234567Patient no
01234567Patient number
01234567gibberigh
01234567me
01234567medical
01234567medical number
01234567medical record number
01234567mr #
01234567mr#
01234567mrn
01234567mrn #
01234567mrn#
01234567mro
01234567patient id
01234567patient identification
01234567patient name
01234567patient no
01234567patient number
12345678 GIBBERIGH
12345678 Gibberigh
12345678 ME
12345678 MEDICAL
12345678 MEDICAL NUMBER
12345678 MEDICAL RECORD NUMBER
12345678 MR #
12345678 MR#
12345678 MRN
12345678 MRN #
12345678 MRN#
12345678 MRO
12345678 Me
12345678 Medical
12345678 Medical number
12345678 Medical record number
12345678 Mr #
12345678 Mr#
12345678 Mrn
12345678 Mrn #
12345678 Mrn#
12345678 Mro
12345678 PATIENT ID
12345678 PATIENT IDENTIFICATION
12345678 PATIENT NAME
12345678 PATIENT NO
12345678 PATIENT NUMBER
12345678 Patient id
12345678 Patient identification
12345678 Patient name
12345678 Patient no
12345678 Patient number
12345678 gibberigh
12345678 me
12345678 medical
12345678 medical number
12345678 medical record number
12345678 mr #
12345678 mr#
12345678 mrn
12345678 mrn #
12345678 mrn#
12345678 mro
12345678 patient id
12345678 patient identification
12345678 patient name
12345678 patient no
12345678 patient number
12345678GIBBERIGH
12345678Gibberigh
12345678ME
12345678MEDICAL
12345678MEDICAL NUMBER
12345678MEDICAL RECORD NUMBER
12345678MR #
12345678MR#
12345678MRN
12345678MRN #
12345678MRN#
12345678MRO
12345678Me
12345678Medical
12345678Medical number
12345678Medical record number
12345678Mr #
12345678Mr#
12345678Mrn
12345678Mrn #
12345678Mrn#
12345678Mro
12345678PATIENT ID
12345678PATIENT IDENTIFICATION
12345678PATIENT NAME
12345678PATIENT NO
12345678PATIENT NUMBER
12345678Patient id
12345678Patient identification
12345678Patient name
12345678Patient no
12345678Patient number
12345678gibberigh
12345678me
12345678medical
12345678medical number
12345678medical record number
12345678mr #
12345678mr#
12345678mrn
12345678mrn #
12345678mrn#
12345678mro
12345678patient id
12345678patient identification
12345678patient name
12345678patient no
12345678patient number
GIBBERIGH 00000000
GIBBERIGH 00012345
GIBBERIGH 00123456
GIBBERIGH 01234567
GIBBERIGH 12345678
GIBBERIGH00000000
GIBBERIGH00012345
GIBBERIGH00123456
GIBBERIGH01234567
GIBBERIGH12345678
Gibberigh 00000000
Gibberigh 00012345
Gibberigh 00123456
Gibberigh 01234567
Gibberigh 12345678
Gibberigh00000000
Gibberigh00012345
Gibberigh00123456
Gibberigh01234567
Gibberigh12345678
ME 00000000
ME 00012345
ME 00123456
ME 01234567
ME 12345678
ME00000000
ME00012345
ME00123456
ME01234567
ME12345678
MEDICAL 00000000
MEDICAL 00012345
MEDICAL 00123456
MEDICAL 01234567
MEDICAL 12345678
MEDICAL NUMBER 00000000
MEDICAL NUMBER 00012345
MEDICAL NUMBER 00123456
MEDICAL NUMBER 01234567
MEDICAL NUMBER 12345678
MEDICAL NUMBER00000000
MEDICAL NUMBER00012345
MEDICAL NUMBER00123456
MEDICAL NUMBER01234567
MEDICAL NUMBER12345678
MEDICAL RECORD NUMBER 00000000
MEDICAL RECORD NUMBER 00012345
MEDICAL RECORD NUMBER 00123456
MEDICAL RECORD NUMBER 01234567
MEDICAL RECORD NUMBER 12345678
MEDICAL RECORD NUMBER00000000
MEDICAL RECORD NUMBER00012345
MEDICAL RECORD NUMBER00123456
MEDICAL RECORD NUMBER01234567
MEDICAL RECORD NUMBER12345678
MEDICAL00000000
MEDICAL00012345
MEDICAL00123456
MEDICAL01234567
MEDICAL12345678
MR # 00000000
MR # 00012345
MR # 00123456
MR # 01234567
MR # 12345678
MR #00000000
MR #00012345
MR #00123456
MR #01234567
MR #12345678
MR# 00000000
MR# 00012345
MR# 00123456
MR# 01234567
MR# 12345678
MR#00000000
MR#00012345
MR#00123456
MR#01234567
MR#12345678
MRN # 00000000
MRN # 00012345
MRN # 00123456
MRN # 01234567
MRN # 12345678
MRN #00000000
MRN #00012345
MRN #00123456
MRN #01234567
MRN #12345678
MRN 00000000
MRN 00012345
MRN 00123456
MRN 01234567
MRN 12345678
MRN# 00000000
MRN# 00012345
MRN# 00123456
MRN# 01234567
MRN# 12345678
MRN#00000000
MRN#00012345
MRN#00123456
MRN#01234567
MRN#12345678
MRN00000000
MRN00012345
MRN00123456
MRN01234567
MRN12345678
MRO 00000000
MRO 00012345
MRO 00123456
MRO 01234567
MRO 12345678
MRO00000000
MRO00012345
MRO00123456
MRO01234567
MRO12345678
Me 00000000
Me 00012345
Me 00123456
Me 01234567
Me 12345678
Me00000000
Me00012345
Me00123456
Me01234567
Me12345678
Medical 00000000
Medical 00012345
Medical 00123456
Medical 01234567
Medical 12345678
Medical number 00000000
Medical number 00012345
Medical number 00123456
Medical number 01234567
Medical number 12345678
Medical number00000000
Medical number00012345
Medical number00123456
Medical number01234567
Medical number12345678
Medical record number 00000000
Medical record number 00012345
Medical record number 00123456
Medical record number 01234567
Medical record number 12345678
Medical record number00000000
Medical record number00012345
Medical record number00123456
Medical record number01234567
Medical record number12345678
Medical00000000
Medical00012345
Medical00123456
Medical01234567
Medical12345678
Mr # 00000000
Mr # 00012345
Mr # 00123456
Mr # 01234567
Mr # 12345678
Mr #00000000
Mr #00012345
Mr #00123456
Mr #01234567
Mr #12345678
Mr# 00000000
Mr# 00012345
Mr# 00123456
Mr# 01234567
Mr# 12345678
Mr#00000000
Mr#00012345
Mr#00123456
Mr#01234567
Mr#12345678
Mrn # 00000000
Mrn # 00012345
Mrn # 00123456
Mrn # 01234567
Mrn # 12345678
Mrn #00000000
Mrn #00012345
Mrn #00123456
Mrn #01234567
Mrn #12345678
Mrn 00000000
Mrn 00012345
Mrn 00123456
Mrn 01234567
Mrn 12345678
Mrn# 00000000
Mrn# 00012345
Mrn# 00123456
Mrn# 01234567
Mrn# 12345678
Mrn#00000000
Mrn#00012345
Mrn#00123456
Mrn#01234567
Mrn#12345678
Mrn00000000
Mrn00012345
Mrn00123456
Mrn01234567
Mrn12345678
Mro 00000000
Mro 00012345
Mro 00123456
Mro 01234567
Mro 12345678
Mro00000000
Mro00012345
Mro00123456
Mro01234567
Mro12345678
PATIENT ID 00000000
PATIENT ID 00012345
PATIENT ID 00123456
PATIENT ID 01234567
PATIENT ID 12345678
PATIENT ID00000000
PATIENT ID00012345
PATIENT ID00123456
PATIENT ID01234567
PATIENT ID12345678
PATIENT IDENTIFICATION 00000000
PATIENT IDENTIFICATION 00012345
PATIENT IDENTIFICATION 00123456
PATIENT IDENTIFICATION 01234567
PATIENT IDENTIFICATION 12345678
PATIENT IDENTIFICATION00000000
PATIENT IDENTIFICATION00012345
PATIENT IDENTIFICATION00123456
PATIENT IDENTIFICATION01234567
PATIENT IDENTIFICATION12345678
PATIENT NAME 00000000
PATIENT NAME 00012345
PATIENT NAME 00123456
PATIENT NAME 01234567
PATIENT NAME 12345678
PATIENT NAME00000000
PATIENT NAME00012345
PATIENT NAME00123456
PATIENT NAME01234567
PATIENT NAME12345678
PATIENT NO 00000000
PATIENT NO 00012345
PATIENT NO 00123456
PATIENT NO 01234567
PATIENT NO 12345678
PATIENT NO00000000
PATIENT NO00012345
PATIENT NO00123456
PATIENT NO01234567
PATIENT NO12345678
PATIENT NUMBER 00000000
PATIENT NUMBER 00012345
PATIENT NUMBER 00123456
PATIENT NUMBER 01234567
PATIENT NUMBER 12345678
PATIENT NUMBER00000000
PATIENT NUMBER00012345
PATIENT NUMBER00123456
PATIENT NUMBER01234567
PATIENT NUMBER12345678
Patient id 00000000
Patient id 00012345
Patient id 00123456
Patient id 01234567
Patient id 12345678
Patient id00000000
Patient id00012345
Patient id00123456
Patient id01234567
Patient id12345678
Patient identification 00000000
Patient identification 00012345
Patient identification 00123456
Patient identification 01234567
Patient identification 12345678
Patient identification00000000
Patient identification00012345
Patient identification00123456
Patient identification01234567
Patient identification12345678
Patient name 00000000
Patient name 00012345
Patient name 00123456
Patient name 01234567
Patient name 12345678
Patient name00000000
Patient name00012345
Patient name00123456
Patient name01234567
Patient name12345678
Patient no 00000000
Patient no 00012345
Patient no 00123456
Patient no 01234567
Patient no 12345678
Patient no00000000
Patient no00012345
Patient no00123456
Patient no01234567
Patient no12345678
Patient number 00000000
Patient number 00012345
Patient number 00123456
Patient number 01234567
Patient number 12345678
Patient number00000000
Patient number00012345
Patient number00123456
Patient number01234567
Patient number12345678
gibberigh 00000000
gibberigh 00012345
gibberigh 00123456
gibberigh 01234567
gibberigh 12345678
gibberigh00000000
gibberigh00012345
gibberigh00123456
gibberigh01234567
gibberigh12345678
me 00000000
me 00012345
me 00123456
me 01234567
me 12345678
me00000000
me00012345
me00123456
me01234567
me12345678
medical 00000000
medical 00012345
medical 00123456
medical 01234567
medical 12345678
medical number 00000000
medical number 00012345
medical number 00123456
medical number 01234567
medical number 12345678
medical number00000000
medical number00012345
medical number00123456
medical number01234567
medical number12345678
medical record number 00000000
medical record number 00012345
medical record number 00123456
medical record number 01234567
medical record number 12345678
medical record number00000000
medical record number00012345
medical record number00123456
medical record number01234567
medical record number12345678
medical00000000
medical00012345
medical00123456
medical01234567
medical12345678
mr # 00000000
mr # 00012345
mr # 00123456
mr # 01234567
mr # 12345678
mr #00000000
mr #00012345
mr #00123456
mr #01234567
mr #12345678
mr# 00000000
mr# 00012345
mr# 00123456
mr# 01234567
mr# 12345678
mr#00000000
mr#00012345
mr#00123456
mr#01234567
mr#12345678
mrn # 00000000
mrn # 00012345
mrn # 00123456
mrn # 01234567
mrn # 12345678
mrn #00000000
mrn #00012345
mrn #00123456
mrn #01234567
mrn #12345678
mrn 00000000
mrn 00012345
mrn 00123456
mrn 01234567
mrn 12345678
mrn# 00000000
mrn# 00012345
mrn# 00123456
mrn# 01234567
mrn# 12345678
mrn#00000000
mrn#00012345
mrn#00123456
mrn#01234567
mrn#12345678
mrn00000000
mrn00012345
mrn00123456
mrn01234567
mrn12345678
mro 00000000
mro 00012345
mro 00123456
mro 01234567
mro 12345678
mro00000000
mro00012345
mro00123456
mro01234567
mro12345678
patient id 00000000
patient id 00012345
patient id 00123456
patient id 01234567
patient id 12345678
patient id00000000
patient id00012345
patient id00123456
patient id01234567
patient id12345678
patient identification 00000000
patient identification 00012345
patient identification 00123456
patient identification 01234567
patient identification 12345678
patient identification00000000
patient identification00012345
patient identification00123456
patient identification01234567
patient identification12345678
patient name 00000000
patient name 00012345
patient name 00123456
patient name 01234567
patient name 12345678
patient name00000000
patient name00012345
patient name00123456
patient name01234567
patient name12345678
patient no 00000000
patient no 00012345
patient no 00123456
patient no 01234567
patient no 12345678
patient no00000000
patient no00012345
patient no00123456
patient no01234567
patient no12345678
patient number 00000000
patient number 00012345
patient number 00123456
patient number 01234567
patient number 12345678
patient number00000000
patient number00012345
patient number00123456
patient number01234567
patient number12345678
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)