re = /(?<!:)(\/\/).+$|\/\*[\s\S]+\*\//m
str = '// comments at the beginning of the file are removed
/*
Block comments are removed - easy peasy
*/
https://urls.are.preserved.for.you// and comments after them are removed
asdfasdf// the comment can bump right up to text
asdfasdf;// ...or a semicolon.
{
foo:// you will need a parser to remove this comment b/c it smells like a URL
"bar",// ...but not this one
boo: // ...or this one
"who"
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end