using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[1-9]|1[0-2]):[0-5][0-9]\s(?:[aApP](\.?)[mM]\1)?$";
string input = @"1:23 am";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}