$re = '/(YY){1,2}([\.\/-])(MM|Mmm)\2(DD)/';
$str = 'YY-MM-DD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);