package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Regex\d{3}`)
var str = `Regex
Regex2
Regex20
Regex201
Regex2017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}