package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\%\(\s*[\w\s\$\(\)=\.]*\s*\)`)
var str = `%( LOOP on object.field )
%( IF )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}