re = /^(000[1-9]|00[1-9]\d|0[1-9]\d\d|100\d|10[1-9]\d|1[1-9]\d{2}|[2-9]\d{3}|[1-9]\d{4}|1\d{5}|2[0-6]\d{4}|27[0-4]\d{3}|275[0-6]\d{2}|2757[0-5]\d|275760)-(0[1-9]|1[012])-(0[1-9]|[12]\d|3[01])$/m
str = '2018-06-14
Min possible year :
0001-05-31
Max possible year :
275760-01-01
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end