$re = '/^(([+])39)?((3[1-6][0-9]))(\d{7})$/m';
$str = '3491234567
+393491234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);