package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-+]?([1-8]?\d(\.\d+)?|90(\.0+)?),\s*[-+]?(180(\.0+)?|((1[0-7]\d)|([1-9]?\d))(\.\d+)?)`)
var str = `dfdf 47.1231231,179.99999999 dsgdfg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}