package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[n-n-N](.+)[g-g-G](.+)([r-r-R]|[a-a-A]|among us free)`)
var str = `nigeria`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}