package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*(?:(?:youtu.be\/)|(?:v\/)|(?:\/u\/\w\/)|(?:embed\/)|(?:watch\?))\??v?=?([^#\&\?]*).*`)
var str = `//www.youtube.com/watch?v=GuOa0MraDEw&t=34s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}