package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*:?\s*([0-9\-]{5,})`)
var str = `My phone number is: 4553333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}