import Foundation
let pattern = #"^[0-9]*([а-яА-Яё\,\. \(\)\-]+([0-9]+)?)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
деревня Николо-Хованское, 217, поселение Сосенское, Москва
улица Алымова 5
Улица Народного Ополчения 45 (со стороны д. 47)
Ул. Большая Филёвская, д. 3, к. 4
Большая Филевская 3к4, подъезд 3
Большая филевска улица д3к4
Большая Филевская 3к4
Большая Филёвская 3к4
Большая филевская 3к4
Большая Филевская 3к4
Большая Филевская дом 3 корпус 4 , 3 подъезд
Большая Филевская 3к4
Большая Филевская 3к4
Большая Филевская 3к4
Врачебный проезд 3
Парковка рядом с домами ул. Коптевская, д. 20к2 и ул. Коптевская, д. 18Ак3
Улица Планерная 12
деревня Николо-Хованское, 200соор1, поселение Сосенское, Москва
Улица 1905 года 25
2
Большая Филевская, дом 3, корпус 4
Погонный проезд 12к1
Москва, поселение Первомайское, д. Каменка, ул. Кленовая, д.1А, стр.1
Большая Филевская 3 кор 4, подъезд 3
Ул.Новочеремушкинская д.31
Новопесчаная д2А
Большая Якиманка 52 двор
сельскохозяйственная ул 20, к 2
Сельскохозяйственная 20 к3
Сельскохозяйственная 20к2
Кронштадтский бульвар, парковочные карманы вдоль владения 6 (порядка 300 м)
Плющиха 9 стр 2
Руставели 15б
1
Весенняя д. 4
Москва, Поселение Новофедоровское, квартал 180. Координаты: 55.448734, 36.977061
1
1
Погонный проезд, 12к1
Погонный проезд, 12к1
Ул. Раздельная
Деревня Саларьево улица 1-Ая Новая д 7/2 кадастровый номер 77:17:0110301:336
12-я парковая 5 и 12-я парковая 7
Алтуфьевское шоссе 27 напротив тц лучик
Алтуфьевское шоссе 27 вначале дома
Сумской проезд 12/5
Погонный проезд, 12к1
4
Беговая 4
Цветной бульвар дом 21стр.1
Ул Василия Петушкова 20, к.1
Москва, улица Первомайская, дом 100
Ул. Раздельная
Город Москва, улица Мясницкая, дом 22, строение 1. Вход во двор со стороны Банковского переулка.
Воронцовская 26
Чусовская улица 17/40
Героев Панфиловцев 17 к2
Спартаковский переулок 24с2
Красных зорь 33а
Берсеневская набережная, 14с5
Проезд Черского 21б
Героев Панфиловцев 17 к2
Проезд Шокальского, 15
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)