import Foundation
let pattern = #"\/produto\/(.*)(.)(html)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://atacadogames.com/produto/jogo-sword-art-497329.html
https://atacadogames.com/produto/carregador-usb-pikachu-446839.html
https://atacadogames.com/produto/jogo-arms-switch-419772.html
\/produto\/(.*)(.)(html)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)