package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\+39([0-9]{9,15})`)
var str = `+39932312345234124
+33920370024
3920370024
+39392037002/^123456$/
/\(?([+39])\)?([ .-]?)([0-9]{3})\2([0-9]{10,15})/
(^\+39$)([ .-]?)([0-9]{3})\2([0-9]{9,15})`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}