# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([[:alnum:]][[:punct:]]\t))*(([ ])*)((.)*)"
test_str = ("We are working to set up a meeting with the SAP demo resource to:\n"
"1. See the demo beforehand\n"
"2. Ask some questions the client is interested in\n"
"a. How is the returned document routed, and can this be defined?\n"
"b. Can status of the returned document trigger notifications/field updates?\n"
"3. Answer Questions I have\n"
"a. Can signers be assigned logically, i.e. like an Agreement template, or only manually?\n"
"b. Can cc’s be automatically assigned?\n"
"c. The screen shots show different categories of signers Internal/External. Does this affect functionality, or is it just for data collection?\n"
"d. What alternative authentication types are supported?\n"
"e. Is Document Cloud copy automatically deleted?\n"
"f. The screen shots don’t show the ability to send comments. Is this possible?\n"
"g. Can you define completion deadlines during sending?\n"
"h. Do you have the ability to turn on “Preview & Add Signature Fields”?\n"
"i. It is unclear in the screen shots if sending multiple documents is possible.")
subst = "\\5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.