#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^[PEIA][a-z]+\/[a-zA-Z_\-\/]+)|(?:^UTC$)"
Local $sString = "Africa/Accra" & @CRLF & _
"Africa/Addis_Ababa" & @CRLF & _
"Africa/Algiers" & @CRLF & _
"Africa/Asmara" & @CRLF & _
"Africa/Asmera" & @CRLF & _
"Africa/Bamako" & @CRLF & _
"Africa/Bangui" & @CRLF & _
"Africa/Banjul" & @CRLF & _
"Africa/Bissau" & @CRLF & _
"Africa/Blantyre" & @CRLF & _
"Africa/Brazzaville" & @CRLF & _
"Africa/Bujumbura" & @CRLF & _
"Africa/Cairo" & @CRLF & _
"Africa/Casablanca" & @CRLF & _
"Africa/Ceuta" & @CRLF & _
"Africa/Conakry" & @CRLF & _
"Africa/Dakar" & @CRLF & _
"Africa/Dar_es_Salaam" & @CRLF & _
"Africa/Djibouti" & @CRLF & _
"Africa/Douala" & @CRLF & _
"Africa/El_Aaiun" & @CRLF & _
"Africa/Freetown" & @CRLF & _
"Africa/Gaborone" & @CRLF & _
"Africa/Harare" & @CRLF & _
"Africa/Johannesburg" & @CRLF & _
"Africa/Juba" & @CRLF & _
"Africa/Kampala" & @CRLF & _
"Africa/Khartoum" & @CRLF & _
"Africa/Kigali" & @CRLF & _
"Africa/Kinshasa" & @CRLF & _
"Africa/Lagos" & @CRLF & _
"Africa/Libreville" & @CRLF & _
"Africa/Lome" & @CRLF & _
"Africa/Luanda" & @CRLF & _
"Africa/Lubumbashi" & @CRLF & _
"Africa/Lusaka" & @CRLF & _
"Africa/Malabo" & @CRLF & _
"Africa/Maputo" & @CRLF & _
"Africa/Maseru" & @CRLF & _
"Africa/Mbabane" & @CRLF & _
"Africa/Mogadishu" & @CRLF & _
"Africa/Monrovia" & @CRLF & _
"Africa/Nairobi" & @CRLF & _
"Africa/Ndjamena" & @CRLF & _
"Africa/Niamey" & @CRLF & _
"Africa/Nouakchott" & @CRLF & _
"Africa/Ouagadougou" & @CRLF & _
"Africa/Porto-Novo" & @CRLF & _
"Africa/Sao_Tome" & @CRLF & _
"Africa/Timbuktu" & @CRLF & _
"Africa/Tripoli" & @CRLF & _
"Africa/Tunis" & @CRLF & _
"Africa/Windhoek" & @CRLF & _
"America/Adak" & @CRLF & _
"America/Anchorage" & @CRLF & _
"America/Anguilla" & @CRLF & _
"America/Antigua" & @CRLF & _
"America/Araguaina" & @CRLF & _
"America/Argentina/Buenos_Aires" & @CRLF & _
"America/Argentina/Catamarca" & @CRLF & _
"America/Argentina/ComodRivadavia" & @CRLF & _
"America/Argentina/Cordoba" & @CRLF & _
"America/Argentina/Jujuy" & @CRLF & _
"America/Argentina/La_Rioja" & @CRLF & _
"America/Argentina/Mendoza" & @CRLF & _
"America/Argentina/Rio_Gallegos" & @CRLF & _
"America/Argentina/Salta" & @CRLF & _
"America/Argentina/San_Juan" & @CRLF & _
"America/Argentina/San_Luis" & @CRLF & _
"America/Argentina/Tucuman" & @CRLF & _
"America/Argentina/Ushuaia" & @CRLF & _
"America/Aruba" & @CRLF & _
"America/Asuncion" & @CRLF & _
"America/Atikokan" & @CRLF & _
"America/Atka" & @CRLF & _
"America/Bahia" & @CRLF & _
"America/Bahia_Banderas" & @CRLF & _
"America/Barbados" & @CRLF & _
"America/Belem" & @CRLF & _
"America/Belize" & @CRLF & _
"America/Blanc-Sablon" & @CRLF & _
"America/Boa_Vista" & @CRLF & _
"America/Bogota" & @CRLF & _
"America/Boise" & @CRLF & _
"America/Buenos_Aires" & @CRLF & _
"America/Cambridge_Bay" & @CRLF & _
"America/Campo_Grande" & @CRLF & _
"America/Cancun" & @CRLF & _
"America/Caracas" & @CRLF & _
"America/Catamarca" & @CRLF & _
"America/Cayenne" & @CRLF & _
"America/Cayman" & @CRLF & _
"America/Chicago" & @CRLF & _
"America/Chihuahua" & @CRLF & _
"America/Coral_Harbour" & @CRLF & _
"America/Cordoba" & @CRLF & _
"America/Costa_Rica" & @CRLF & _
"America/Creston" & @CRLF & _
"America/Cuiaba" & @CRLF & _
"America/Curacao" & @CRLF & _
"America/Danmarkshavn" & @CRLF & _
"America/Dawson" & @CRLF & _
"America/Dawson_Creek" & @CRLF & _
"America/Denver" & @CRLF & _
"America/Detroit" & @CRLF & _
"America/Dominica" & @CRLF & _
"America/Edmonton" & @CRLF & _
"America/Eirunepe" & @CRLF & _
"America/El_Salvador" & @CRLF & _
"America/Ensenada" & @CRLF & _
"America/Fortaleza" & @CRLF & _
"America/Fort_Nelson" & @CRLF & _
"America/Fort_Wayne" & @CRLF & _
"America/Glace_Bay" & @CRLF & _
"America/Godthab" & @CRLF & _
"America/Goose_Bay" & @CRLF & _
"America/Grand_Turk" & @CRLF & _
"America/Grenada" & @CRLF & _
"America/Guadeloupe" & @CRLF & _
"America/Guatemala" & @CRLF & _
"America/Guayaquil" & @CRLF & _
"America/Guyana" & @CRLF & _
"America/Halifax" & @CRLF & _
"America/Havana" & @CRLF & _
"America/Hermosillo" & @CRLF & _
"America/Indiana/Indianapolis" & @CRLF & _
"America/Indiana/Knox" & @CRLF & _
"America/Indiana/Marengo" & @CRLF & _
"America/Indiana/Petersburg" & @CRLF & _
"America/Indiana/Tell_City" & @CRLF & _
"America/Indiana/Vevay" & @CRLF & _
"America/Indiana/Vincennes" & @CRLF & _
"America/Indiana/Winamac" & @CRLF & _
"America/Indianapolis" & @CRLF & _
"America/Inuvik" & @CRLF & _
"America/Iqaluit" & @CRLF & _
"America/Jamaica" & @CRLF & _
"America/Jujuy" & @CRLF & _
"America/Juneau" & @CRLF & _
"America/Kentucky/Louisville" & @CRLF & _
"America/Kentucky/Monticello" & @CRLF & _
"America/Knox_IN" & @CRLF & _
"America/Kralendijk" & @CRLF & _
"America/La_Paz" & @CRLF & _
"America/Lima" & @CRLF & _
"America/Los_Angeles" & @CRLF & _
"America/Louisville" & @CRLF & _
"America/Lower_Princes" & @CRLF & _
"America/Maceio" & @CRLF & _
"America/Managua" & @CRLF & _
"America/Manaus" & @CRLF & _
"America/Marigot" & @CRLF & _
"America/Martinique" & @CRLF & _
"America/Matamoros" & @CRLF & _
"America/Mazatlan" & @CRLF & _
"America/Mendoza" & @CRLF & _
"America/Menominee" & @CRLF & _
"America/Merida" & @CRLF & _
"America/Metlakatla" & @CRLF & _
"America/Mexico_City" & @CRLF & _
"America/Miquelon" & @CRLF & _
"America/Moncton" & @CRLF & _
"America/Monterrey" & @CRLF & _
"America/Montevideo" & @CRLF & _
"America/Montreal" & @CRLF & _
"America/Montserrat" & @CRLF & _
"America/Nassau" & @CRLF & _
"America/New_York" & @CRLF & _
"America/Nipigon" & @CRLF & _
"America/Nome" & @CRLF & _
"America/Noronha" & @CRLF & _
"America/North_Dakota/Beulah" & @CRLF & _
"America/North_Dakota/Center" & @CRLF & _
"America/North_Dakota/New_Salem" & @CRLF & _
"America/Ojinaga" & @CRLF & _
"America/Panama" & @CRLF & _
"America/Pangnirtung" & @CRLF & _
"America/Paramaribo" & @CRLF & _
"America/Phoenix" & @CRLF & _
"America/Port-au-Prince" & @CRLF & _
"America/Porto_Acre" & @CRLF & _
"America/Porto_Velho" & @CRLF & _
"America/Port_of_Spain" & @CRLF & _
"America/Puerto_Rico" & @CRLF & _
"America/Rainy_River" & @CRLF & _
"America/Rankin_Inlet" & @CRLF & _
"America/Recife" & @CRLF & _
"America/Regina" & @CRLF & _
"America/Resolute" & @CRLF & _
"America/Rio_Branco" & @CRLF & _
"America/Rosario" & @CRLF & _
"America/Santarem" & @CRLF & _
"America/Santiago" & @CRLF & _
"America/Santo_Domingo" & @CRLF & _
"America/Sao_Paulo" & @CRLF & _
"America/Scoresbysund" & @CRLF & _
"America/Shiprock" & @CRLF & _
"America/Sitka" & @CRLF & _
"America/St_Barthelemy" & @CRLF & _
"America/St_Johns" & @CRLF & _
"America/St_Kitts" & @CRLF & _
"America/St_Lucia" & @CRLF & _
"America/St_Thomas" & @CRLF & _
"America/St_Vincent" & @CRLF & _
"America/Swift_Current" & @CRLF & _
"America/Tegucigalpa" & @CRLF & _
"America/Thule" & @CRLF & _
"America/Thunder_Bay" & @CRLF & _
"America/Tijuana" & @CRLF & _
"America/Toronto" & @CRLF & _
"America/Tortola" & @CRLF & _
"America/Vancouver" & @CRLF & _
"America/Virgin" & @CRLF & _
"America/Whitehorse" & @CRLF & _
"America/Winnipeg" & @CRLF & _
"America/Yakutat" & @CRLF & _
"America/Yellowknife" & @CRLF & _
"Antarctica/Casey" & @CRLF & _
"Antarctica/Davis" & @CRLF & _
"Antarctica/DumontDUrville" & @CRLF & _
"Antarctica/Mawson" & @CRLF & _
"Antarctica/McMurdo" & @CRLF & _
"Antarctica/Palmer" & @CRLF & _
"Antarctica/Rothera" & @CRLF & _
"Antarctica/South_Pole" & @CRLF & _
"Antarctica/Syowa" & @CRLF & _
"Antarctica/Vostok" & @CRLF & _
"Asia/Aden" & @CRLF & _
"Asia/Almaty" & @CRLF & _
"Asia/Amman" & @CRLF & _
"Asia/Anadyr" & @CRLF & _
"Asia/Aqtau" & @CRLF & _
"Asia/Aqtobe" & @CRLF & _
"Asia/Ashgabat" & @CRLF & _
"Asia/Ashkhabad" & @CRLF & _
"Asia/Atyrau" & @CRLF & _
"Asia/Baghdad" & @CRLF & _
"Asia/Bahrain" & @CRLF & _
"Asia/Baku" & @CRLF & _
"Asia/Bangkok" & @CRLF & _
"Asia/Barnaul" & @CRLF & _
"Asia/Beirut" & @CRLF & _
"Asia/Bishkek" & @CRLF & _
"Asia/Brunei" & @CRLF & _
"Asia/Calcutta" & @CRLF & _
"Asia/Chita" & @CRLF & _
"Asia/Choibalsan" & @CRLF & _
"Asia/Chongqing" & @CRLF & _
"Asia/Chungking" & @CRLF & _
"Asia/Colombo" & @CRLF & _
"Asia/Dacca" & @CRLF & _
"Asia/Damascus" & @CRLF & _
"Asia/Dhaka" & @CRLF & _
"Asia/Dili" & @CRLF & _
"Asia/Dubai" & @CRLF & _
"Asia/Dushanbe" & @CRLF & _
"Asia/Gaza" & @CRLF & _
"Asia/Harbin" & @CRLF & _
"Asia/Hebron" & @CRLF & _
"Asia/Hong_Kong" & @CRLF & _
"Asia/Hovd" & @CRLF & _
"Asia/Ho_Chi_Minh" & @CRLF & _
"Asia/Irkutsk" & @CRLF & _
"Asia/Istanbul" & @CRLF & _
"Asia/Jakarta" & @CRLF & _
"Asia/Jayapura" & @CRLF & _
"Asia/Jerusalem" & @CRLF & _
"Asia/Kabul" & @CRLF & _
"Asia/Kamchatka" & @CRLF & _
"Asia/Karachi" & @CRLF & _
"Asia/Kashgar" & @CRLF & _
"Asia/Kathmandu" & @CRLF & _
"Asia/Katmandu" & @CRLF & _
"Asia/Khandyga" & @CRLF & _
"Asia/Kolkata" & @CRLF & _
"Asia/Krasnoyarsk" & @CRLF & _
"Asia/Kuala_Lumpur" & @CRLF & _
"Asia/Kuching" & @CRLF & _
"Asia/Kuwait" & @CRLF & _
"Asia/Macao" & @CRLF & _
"Asia/Macau" & @CRLF & _
"Asia/Magadan" & @CRLF & _
"Asia/Makassar" & @CRLF & _
"Asia/Manila" & @CRLF & _
"Asia/Muscat" & @CRLF & _
"Asia/Nicosia" & @CRLF & _
"Asia/Novokuznetsk" & @CRLF & _
"Asia/Novosibirsk" & @CRLF & _
"Asia/Omsk" & @CRLF & _
"Asia/Oral" & @CRLF & _
"Asia/Phnom_Penh" & @CRLF & _
"Asia/Pontianak" & @CRLF & _
"Asia/Pyongyang" & @CRLF & _
"Asia/Qatar" & @CRLF & _
"Asia/Qyzylorda" & @CRLF & _
"Asia/Rangoon" & @CRLF & _
"Asia/Riyadh" & @CRLF & _
"Asia/Saigon" & @CRLF & _
"Asia/Sakhalin" & @CRLF & _
"Asia/Samarkand" & @CRLF & _
"Asia/Seoul" & @CRLF & _
"Asia/Shanghai" & @CRLF & _
"Asia/Singapore" & @CRLF & _
"Asia/Srednekolymsk" & @CRLF & _
"Asia/Taipei" & @CRLF & _
"Asia/Tashkent" & @CRLF & _
"Asia/Tbilisi" & @CRLF & _
"Asia/Tehran" & @CRLF & _
"Asia/Tel_Aviv" & @CRLF & _
"Asia/Thimbu" & @CRLF & _
"Asia/Thimphu" & @CRLF & _
"Asia/Tokyo" & @CRLF & _
"Asia/Tomsk" & @CRLF & _
"Asia/Ujung_Pandang" & @CRLF & _
"Asia/Ulaanbaatar" & @CRLF & _
"Asia/Ulan_Bator" & @CRLF & _
"Asia/Urumqi" & @CRLF & _
"Asia/Ust-Nera" & @CRLF & _
"Asia/Vientiane" & @CRLF & _
"Asia/Vladivostok" & @CRLF & _
"Asia/Yakutsk" & @CRLF & _
"Asia/Yangon" & @CRLF & _
"Asia/Yekaterinburg" & @CRLF & _
"Asia/Yerevan" & @CRLF & _
"Atlantic/Azores" & @CRLF & _
"Atlantic/Bermuda" & @CRLF & _
"Atlantic/Canary" & @CRLF & _
"Atlantic/Cape_Verde" & @CRLF & _
"Atlantic/Faeroe" & @CRLF & _
"Atlantic/Faroe" & @CRLF & _
"Atlantic/Jan_Mayen" & @CRLF & _
"Atlantic/Madeira" & @CRLF & _
"Atlantic/Reykjavik" & @CRLF & _
"Atlantic/South_Georgia" & @CRLF & _
"Atlantic/Stanley" & @CRLF & _
"Atlantic/St_Helena" & @CRLF & _
"Australia/ACT" & @CRLF & _
"Australia/Adelaide" & @CRLF & _
"Australia/Brisbane" & @CRLF & _
"Australia/Broken_Hill" & @CRLF & _
"Australia/Canberra" & @CRLF & _
"Australia/Currie" & @CRLF & _
"Australia/Darwin" & @CRLF & _
"Australia/Eucla" & @CRLF & _
"Australia/Hobart" & @CRLF & _
"Australia/Lindeman" & @CRLF & _
"Australia/Lord_Howe" & @CRLF & _
"Australia/Melbourne" & @CRLF & _
"Australia/North" & @CRLF & _
"Australia/NSW" & @CRLF & _
"Australia/Perth" & @CRLF & _
"Australia/Queensland" & @CRLF & _
"Australia/South" & @CRLF & _
"Australia/Sydney" & @CRLF & _
"Australia/Tasmania" & @CRLF & _
"Australia/Victoria" & @CRLF & _
"Australia/West" & @CRLF & _
"Europe/Amsterdam" & @CRLF & _
"Europe/Andorra" & @CRLF & _
"Europe/Astrakhan" & @CRLF & _
"Europe/Athens" & @CRLF & _
"Europe/Belfast" & @CRLF & _
"Europe/Belgrade" & @CRLF & _
"Europe/Berlin" & @CRLF & _
"Europe/Bratislava" & @CRLF & _
"Europe/Brussels" & @CRLF & _
"Europe/Bucharest" & @CRLF & _
"Europe/Budapest" & @CRLF & _
"Europe/Chisinau" & @CRLF & _
"Europe/Copenhagen" & @CRLF & _
"Europe/Dublin" & @CRLF & _
"Europe/Gibraltar" & @CRLF & _
"Europe/Guernsey" & @CRLF & _
"Europe/Helsinki" & @CRLF & _
"Europe/Isle_of_Man" & @CRLF & _
"Europe/Istanbul" & @CRLF & _
"Europe/Jersey" & @CRLF & _
"Europe/Kaliningrad" & @CRLF & _
"Europe/Kiev" & @CRLF & _
"Europe/Kirov" & @CRLF & _
"Europe/Lisbon" & @CRLF & _
"Europe/Ljubljana" & @CRLF & _
"Europe/London" & @CRLF & _
"Europe/Luxembourg" & @CRLF & _
"Europe/Madrid" & @CRLF & _
"Europe/Malta" & @CRLF & _
"Europe/Mariehamn" & @CRLF & _
"Europe/Minsk" & @CRLF & _
"Europe/Monaco" & @CRLF & _
"Europe/Moscow" & @CRLF & _
"Europe/Nicosia" & @CRLF & _
"Europe/Oslo" & @CRLF & _
"Europe/Paris" & @CRLF & _
"Europe/Podgorica" & @CRLF & _
"Europe/Prague" & @CRLF & _
"Europe/Riga" & @CRLF & _
"Europe/Rome" & @CRLF & _
"Europe/Samara" & @CRLF & _
"Europe/San_Marino" & @CRLF & _
"Europe/Sarajevo" & @CRLF & _
"Europe/Saratov" & @CRLF & _
"Europe/Simferopol" & @CRLF & _
"Europe/Skopje" & @CRLF & _
"Europe/Sofia" & @CRLF & _
"Europe/Stockholm" & @CRLF & _
"Europe/Tallinn" & @CRLF & _
"Europe/Tirane" & @CRLF & _
"Europe/Tiraspol" & @CRLF & _
"Europe/Uzhgorod" & @CRLF & _
"Europe/Vaduz" & @CRLF & _
"Europe/Vatican" & @CRLF & _
"Europe/Vienna" & @CRLF & _
"Europe/Vilnius" & @CRLF & _
"Europe/Volgograd" & @CRLF & _
"Europe/Warsaw" & @CRLF & _
"Europe/Zagreb" & @CRLF & _
"Europe/Zaporozhye" & @CRLF & _
"Europe/Zurich" & @CRLF & _
"Indian/Antananarivo" & @CRLF & _
"Indian/Chagos" & @CRLF & _
"Indian/Christmas" & @CRLF & _
"Indian/Cocos" & @CRLF & _
"Indian/Comoro" & @CRLF & _
"Indian/Kerguelen" & @CRLF & _
"Indian/Mahe" & @CRLF & _
"Indian/Maldives" & @CRLF & _
"Indian/Mauritius" & @CRLF & _
"Indian/Mayotte" & @CRLF & _
"Indian/Reunion" & @CRLF & _
"Pacific/Apia" & @CRLF & _
"Pacific/Auckland" & @CRLF & _
"Pacific/Chatham" & @CRLF & _
"Pacific/Chuuk" & @CRLF & _
"Pacific/Easter" & @CRLF & _
"Pacific/Efate" & @CRLF & _
"Pacific/Enderbury" & @CRLF & _
"Pacific/Fakaofo" & @CRLF & _
"Pacific/Fiji" & @CRLF & _
"Pacific/Funafuti" & @CRLF & _
"Pacific/Galapagos" & @CRLF & _
"Pacific/Gambier" & @CRLF & _
"Pacific/Guadalcanal" & @CRLF & _
"Pacific/Guam" & @CRLF & _
"Pacific/Honolulu" & @CRLF & _
"Pacific/Johnston" & @CRLF & _
"Pacific/Kiritimati" & @CRLF & _
"Pacific/Kosrae" & @CRLF & _
"Pacific/Kwajalein" & @CRLF & _
"Pacific/Majuro" & @CRLF & _
"Pacific/Marquesas" & @CRLF & _
"Pacific/Midway" & @CRLF & _
"Pacific/Nauru" & @CRLF & _
"Pacific/Niue" & @CRLF & _
"Pacific/Norfolk" & @CRLF & _
"Pacific/Noumea" & @CRLF & _
"Pacific/Pago_Pago" & @CRLF & _
"Pacific/Palau" & @CRLF & _
"Pacific/Pitcairn" & @CRLF & _
"Pacific/Pohnpei" & @CRLF & _
"Pacific/Ponape" & @CRLF & _
"Pacific/Port_Moresby" & @CRLF & _
"Pacific/Rarotonga" & @CRLF & _
"Pacific/Saipan" & @CRLF & _
"Pacific/Samoa" & @CRLF & _
"Pacific/Tahiti" & @CRLF & _
"Pacific/Tarawa" & @CRLF & _
"Pacific/Tongatapu" & @CRLF & _
"Pacific/Truk" & @CRLF & _
"Pacific/Wake" & @CRLF & _
"Pacific/Wallis" & @CRLF & _
"Pacific/Yap" & @CRLF & _
"UTC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")