$re = '/^((http[s]?):\/)?\/?([^:\/\s]+)((amazonaws)*\/)([\w-\.]+[^#?\s]+)/mi';
$str = 'https://s3-us-west-2.amazonaws.com/offer-creatives-dev-cdn/3455-422D9D55A6F5C55D5D9B508386FF0DA3231AD489.jpg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);