import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?UserID=\"(?<UserID>.*?)\".*?UserName=\"(?<UserName>.*?)\".*?NetworkAccessPointID=\"(?<IPAddress>.*?)\".*?EventDateTime=\"(?<DateTime>.*?)\".*?EventOutcomeIndicator=\"(?<OutcomeIndicator>.*?)\".*?csd-code=\"(?<csd_code>.*?)\".*?AuditEnterpriseSiteID=\"(?<Site>.*?)\".*?ParticipantObjectID=\"(?<PatientID>.*?)\".*?ParticipantObjectTypeCode=\"(?<ObjectTypeCode>.*?)\".*?";
final String string = "<AuditMessage xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"
+ " <ActiveParticipant UserID=\"10361\" UserIsRequestor=\"true\" UserName=\"Alexander Hardin\" NetworkAccessPointID=\"184.190.165.174\" NetworkAccessPointTypeCode=\"2\" />\n"
+ " <EventIdentification EventDateTime=\"2022-08-15T04:26:37+0000\" EventOutcomeIndicator=\"0\" EventActionCode=\"R\">\n"
+ " <EventID codeSystemName=\"DCM\" csd-code=\"110110\" originalText=\"Patient Record\" />\n"
+ " </EventIdentification>\n"
+ " <AuditSourceIdentification AuditSourceID=\"Carepointe\" AuditEnterpriseSiteID=\"AZ\" />\n"
+ " <ParticipantObjectIdentification ParticipantObjectID=\"\" ParticipantObjectTypeCodeRole=\"1\" ParticipantObjectTypeCode=\"1\" ParticipantObjectDataLifeCycle=\"6\">\n"
+ " <ParticipantObjectIDTypeCode>2</ParticipantObjectIDTypeCode>\n"
+ " <ParticipantObjectQuery>U0VMRUNUIFVzZXJfSUQsIEZpcnN0TmFtZSwgTGFzdE5hbWUsIENvbXBhbnksIFJvbGVfSUQgRlJPTSB0YmxfdXNlcnMgV0hFUkUgVXNlcl9JRCA9IDp1aWQ=</ParticipantObjectQuery>\n"
+ " <ParticipantObjectDetail type=\"User_ID\" value=\"MTAzNjE=\" />\n"
+ " </ParticipantObjectIdentification>\n"
+ " <DICOMObjectDescriptionContents>\n"
+ " <Anonymized>0</Anonymized>\n"
+ " <Encrypted>0</Encrypted>\n"
+ " </DICOMObjectDescriptionContents>\n"
+ "</AuditMessage>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}