package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^\s\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)\|([^\|]*)`)
var str = `sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}