package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<capt>.+\/search\/autocomplete\/SearchBox\?term=.{0,150}).*$`)
var str = `/ru/search/autocomplete/SearchBox?term=%D1%83%D0%B2%D0%BB%D0%B0%D0%B6%D0%BD%D1%8F%D1%8E%D1%89%D0%B8%D0%B9%20%D0%BA%D0%BE%D1%80%D1%80%D0%B5%D0%BA%D1%82%D0%B8%D1%80%D1%83%D1%8E%D1%89%D0%B8%D0%B9%20%D1%82%D0%BE%D0%BD%D0%B0%D0%BB%D1%8C%D0%BD%D1%8B%D0%B9%20CC%20%D0%BA%D1%80%D0%B5%D0%BC%20%22%D0%BC%D0%B0%D1%81%D1%82%D0%B5%D1%80%20%D1%86%D0%B2%D0%B5%D1%82%D0%B0
/ru/search/autocomplete/SearchBox?term=%D1%83%D0%B2%D0%BB%D0%B0%D0%B6%D0%BD%D1%8F%D1%8E%D1%89%D0%B8%D0%B9%20%D0%BA%D0%BE%D1%80%D1%80%D0%B5%D0%BA%D1%82%D0%B8%D1%80%D1%83%D1%8E%D1%89%D0%B8%D0%B9%20%D1%82%D0%BE%D0%BD%D0%B0%D0%BB%D1%8C%D0%BD%D1%8B%D0%B9%20CC%20%D0%BA%D1%80%D0%B5%D0%BC%20%22%D0%BC%D0%B0%D1%81%D1%82%D0%B5%D1%80%20%D1%86%D0%B2%D0%B5
/ru/search/autocomplete/SearchBox?term=https%3A%2F%2Fnew.faberlic.com%2Fmedias%2F00271024-460Wx665H%3Fcontext%3DbWFzdGVyfGltYWdlc3wxMTE2NjJ8aW1hZ2UvanBlZ3xzeXMtbWFzdGVyL2ltYWdlcy9oNWMvaDA1L2gwMC84ODg3NTYxNTg0NjcwLzAwMjcxMDI0XzQ2MFd4NjY1SHxmZWE0MWIyZDMwZjAyNGM1YjFlMWZhYzZiODczOWE3NTU5MTU2YTA4ZjZiMWIyYmRjZTJlOTRkMTAxOTBhNzg0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}