// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:go|h[1,3]\-redir02\-v)\.eset\.com|(?:support\-)?go\.eset\.eu$").unwrap();
let string = "go.eset.com
h1-redir02-v.eset.com
h3-redir02-v.eset.com
go.eset.eu
support-go.eset.eu";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}