const regex = /\(??(0\d{1,2}?)\)??(\s*?|-??)(\d{3,4}(\s*?|-??)\d{3,4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(??(0\\d{1,2}?)\\)??(\\s*?|-??)(\\d{3,4}(\\s*?|-??)\\d{3,4})', '')
const str = `
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}