package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`variants\[([0-9]{6})\]\[1\]\[([0-9]{1,6})\] \= 237228\;`)
var str = `var variants = [];
variants[208091] = [[80.00, 958, new Image(), '8.00', 80.00, "LUG-CENTRIC-SPACERS"],{},{},[]];
variants[208091][1][36366] = 237228;
variants[208092] = [[80.00, 941, new Image(), '8.00', 80.00, "4112-5-55-L"],{},{},[]];
variants[208092][1][36366] = 237229;
variants[208093] = [[80.00, 957, new Image(), '8.00', 80.00, "4112-5-55-LM"],{},{},[]];
variants[208093][1][36366] = 237230;
variants[208094] = [[80.00, 954, new Image(/r), '8.00', 80.00, "4112-6-55-L"],{},{},[]];
variants[208094][1][36366] = 237231;
variants[208095] = [[115.00, 948, new Image(1), '8.00', 115.00, "4112-8-65-L"],{},{},[]];
variants[208095][1][36366] = 237232;
variants[208096] = [[115.00, 958, new Image(69), '8.00', 115.00, "4112-8-65-LM"],{},{},[]];
variants[208096][1][36366] = 237233;
variants[216938] = [[80.00, 998, new Image(), '8.00', 80.00, "4112-6-55-14-L"],{},{},[]];
variants[216938][1][36366] = 244691;
variants[216939] = [[115.00, 1000, new Image(), '8.00', 115.00, "4112-8-170-L"],{},{},[]];
variants[216939][1][36366] = 244692;
variants[218025] = [[80.00, 998, new Image(), '8.00', 80.00, "4112-5-45-L"],{},{},[]];
variants[218025][1][36366] = 245809;
variants[228776] = [[115.00, 1000, new Image(), '8.00', 115.00, "4112-8-180-L"],{},{},[]];
variants[228776][1][36366] = 254512;
variants[228819] = [[80.00, 1000, new Image(), '8.00', 80.00, "4112-5-150-L"],{},{},[]];
variants[228819][1][36366] = 254558;
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}