package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([V,E]-[0-9]{6,8})`)
var str = `V-12353333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}