re = / (?=
({%.if
(?:
(?>
(?:
(?! {%.if | endif.%}) .
)+
)*
| (?1)
)*
endif.%})
)
(?1)/xm
str = '{% if something %}
----------------
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
---- endif ----
{% endif %}
kjafgnkajngkjalkjg
{% if something %}
++++++++++++++++
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
++++ endif ++++
{% endif %}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end