import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!\\d.)(3[47]\\d{2}([ -]?)(?!(\\d)\\3{5}|123456|234567|345678|424242|545454)\\d{6}\\2(?!(\\d)\\4{4})\\d{5}|((4\\d|5[1-5]|65)\\d{2}|6011)([ -]?)(?!(\\d)\\8{3}|4242|5454|1234|3456|5678|2345|4567)\\d{4}\\7(?!(\\d)\\9{3})\\d{4}\\7\\d{4})(\\b|\\s)(?!.\\d\\d)";
final String string = "ALL strings in the first section should match\n"
+ "some 4270446050075048\n"
+ "4270-4460-5007-5048\n"
+ "this:4270 4460 5007 5048.\n"
+ "4270 4460 5007 5048 4/20\n"
+ "4270 4460 5007 5048 what\n"
+ "4270 4460 5007 5048\n"
+ "4270 4460 5007 5048 12/20 \n"
+ "5105105105105100\n"
+ "5200828282828210\n\n"
+ "--- (the following should not match - test numbers)\n"
+ "5454545454545454\n"
+ "4123456789012345\n"
+ "4242424242424242\n"
+ "42704460500750a8\n"
+ "4111111111111111\n"
+ "5111111111111111\n"
+ "5555555555555555\n"
+ "3333333333333333\n"
+ "3111111111111111\n\n"
+ "--- (the following should NOT match)\n"
+ "4270 4460 5007 5048 1234\n"
+ "4270\n"
+ "4270 4460 5007 504\n"
+ "42811293test123\n"
+ "427044605007504812345083 5095 5179 5157 5219 5187 5095 <--- FALSE POSITIVE (contains valid CC but has lots of exra digits)\n"
+ "this:4270 4460 5007 50482\n"
+ "4270 4460 5007 5048 123\n"
+ "4270 4460 5007 5048 1234\n\n"
+ "Known False positive (test number):\n"
+ "5535 3545 5455 4444\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}