const regex = new RegExp('^(?!\\b(\\d)\\1+\\b)(?!123456789|002281852|042103580|062360749|078051120|095073645|128036045|135016629|141186941|165167999|165187999|165207999|165227999|165247999|189092294|212097694|212099999|306302348|308125070|468288779|549241889)(?!000|666|9\\d{2})\\d{2}(?!00)\\d{2}(?!0{4})\\d{4}$', '')
const str = `12121234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}