$re = '/^[A-Z]{3}+-[0-9]{3}$/';
$str = 'AAB-456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);