re = /(((https?:\/\/)?(www\.)?facebook\.com\/))?(.*\/)?([a-zA-Z0-9.]*)($|\\?.*)/
str = 'http://facebook.com/almogbaku
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end