$re = '/font-size:\s*\d*\.?\d*\s*px;?/m';
$str = 'font-size: 13.4 px';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);