$re = '/^[a-z]+(_[a-z]+)*$/m';
$str = 'this_is_my_c_private_function';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);