import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ESAAttachmentDetails=.*?'(\\S+\\.\\b(?!eml|p7s|xml)\\b.*?)'.*?\\sESAFriendlyFrom";
final String string = "Sep 09 08:32:28 Qradar_mail_log_monoline: CEF:0|Cisco|C600V Email Security Virtual Appliance|13.0.0-375|ESA_CONSOLIDATED_LOG_EVENT|Consolidated Log 'IndiceBusta.xml' Event|5|deviceExternalId=4218A388D5F87FE03948-AF94EFBF2387 ESAMID=46698525 ESAICID=93560178 ESADCID=12077002 ESAAMPVerdict=NOT_EVALUATED ESAASVerdict=NOT_EVALUATED ESAAVVerdict=NEGATIVE ESACFVerdict=MATCH endTime=Wed Sep 9 08:32:26 2020 ESADLPVerdict=NOT_EVALUATED dvc=172.16.102.105 ESAAttachmentDetails={'smime.p7s': {'BodyScanner': {}}, 'IndiceBusta.xml': {'BodyScanner': {}}, 'postacert.eml': {'BodyScanner': {}}, '976739s.pdf': {'BodyScanner': {}}, 'daticert.xml': {'BodyScanner': {}}, 'Comunicazione.xml': {'BodyScanner': {}}, 'MELCARNE=20ANNA=20PAOLA=20-=20NOTE=20TRATTAZIONE=20SCRITTA.pdf.zip': {'BodyScanner': {}}} ESAFriendlyFrom=posta-certificata@telecompost.it ESAGMVerdict=NEGATIVE startTime=Wed Sep 9 08:32:25 2020 deviceInboundInterface=InComing deviceDirection=0 ESAMailFlowPolicy=ACCEPT suser=forward.mailbox@forward.telecompost.it cs1Label=MailPolicy cs1=INPS cs2Label=SenderCountry cs2=Italy ESAMFVerdict=MATCH act=DELIVERED cs4Label=ExternalMsgID cs4='<1991715585.1180479.1599633145120.JavaMail.root@pecbe1>'";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}