$re = '/^([s|S][e|E][l|L][e|E][c|C][t|T])\s([a-zA-Z0-9\-_]+|\*),?([a-zA-Z0-9\-_]+)*\s([f|F][r|R][o|O][m|M])\s([a-zA-Z0-9\-_]+),?([a-zA-Z0-9\-_]+)*(.*);$/';
$str = 'SELECT * FROM foo WHERE;
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);