import Foundation
let pattern = #"^[A-Z](([a-z]+[A-Z]?)*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABCD
ABCDE
snake_case
camelCase
2PascalCase
streamIOIO
gREATERDtha
MdeADFAFdsADFads
DeviceSNSD
AabcABCD
AabcABCDabcABCD
ABabcABCD
ABabcABCDabcABCD
ABCabcABCD
ABCabcABCDabcABCDabcABCDabcABCD
ABCDabcABCD
ABCDabcABCDabcABCDabcABCDabcABCD
HTMLParser
ABabcABCDbcABC
ABCDabcABC
ABCDabcAB
ABCDabcA
AaABC
AabcABCabcABC
MoeADFdsADFads
ABCabcABC
ABCabcAB
ABabcABC
ABabcAB
AabcAB
ABCabcABCabcA
ABCabcA
Aabc123
AabcABC
AB
ABC
StreamIO
IOStream
DeviceID
DeviceSNS
HELLO
Camel01C
Camel01c01
Camel01C01
Camel01CC01
Camel0a1c1
Camel0a1C1
Camel0ac1b1C1
CamelC1
CamelCA
CamelCa1
CamelCa_1
IbsReleaseTestVerificationRegressioNSuite
Pascal2CaseA
SupportsIpv6OnIos
Affine3D
Pascal2Case
Mode2A
Mode2A2
Mode2A2A
CreateAMode
CreateBMode
ContextHTMLParser
Context
A
Ag
PacalCasePacalCasePacalCasePacalCasePacalCasePacalCase
PascalCase
PascalCaseA
ModeA
MadeEasy
WonderFul
AndMe
HtmlParser
H
AaA
CamelC
IbsReleaseTestVerificationRegressionSuite
IbsReleaseTestVerificationRegressioN
XmlHttpRequest
NewCustomerId
InnerStopwatch
YouTubeImporter
YoutubeImporter
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)