import Foundation
let pattern = #"{([^{}]*)\|album}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{beethoven|artist}'s {piano sonata number twenty-three|track}
{bach|artist}'s {cello preludes|track}
{beethoven|artist}'s {opus fifty-seven sonata|track}
{bach|artist}'s {cello preludes|track} performed by {yo-yo ma|artist}
{Bulgarian womens choir|album}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}