$re = '/^(?=.*\bmeat\b)(?=.*\bpasta\b)(?=.*\bdinner\b).+/';
$str = 'hello meat pasta dinner what?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);