$re = '/^(?=.*[^\.]$)((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.?){4}$/mi';
$str = '999.999.999.999
299.299.299.299
199.199.199.344
192.168.1.123
255.255.255.255
0.0.0.0
000.000.000.000
67.98.159.39
087.052.078.23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);