#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^((qwarebatch[0-9]?_((g?p(tres|[fse])|lc|ra|darf?|n[edlcs]|ob|gru_intra))_)|([AG]F|[EL]?[CO]([ACDV])?|D[CIL]|NT))[0-9]{5,8}\.TXT.*"
Local $sString = "qwarebatch_nc_20140714.TXT" & @CRLF & _
"AF32503.txt" & @CRLF & _
"CV4130214.TXT" & @CRLF & _
"CA5070515.TXT" & @CRLF & _
"CD4130115.txt" & @CRLF & _
"CC4130214.TXT" & @CRLF & _
"DI41102.txt" & @CRLF & _
"qwarebatch_dar_20150602.TXT" & @CRLF & _
"qwarebatch_darf_20150602.TXT" & @CRLF & _
"DC4130214.TXT" & @CRLF & _
"DL4160214.TXT" & @CRLF & _
"EC5070515.TXT" & @CRLF & _
"GF41102.txt" & @CRLF & _
"GP41102.TXT" & @CRLF & _
"qwarebatch_gru_intra_20150602.TXT" & @CRLF & _
"qwarebatch_lc_20150602.TXT" & @CRLF & _
"LO4130214.TXT" & @CRLF & _
"NT32503.txt" & @CRLF & _
"qwarebatch_nd_20150602.TXT" & @CRLF & _
"qwarebatch_ne_20150602.TXT" & @CRLF & _
"qwarebatch_nl_20150602.TXT" & @CRLF & _
"qwarebatch_ns_20150602.TXT" & @CRLF & _
"qwarebatch_ob_20150602.TXT" & @CRLF & _
"qwarebatch_pe_20140618.TXT" & @CRLF & _
"qwarebatch_pf_20150602.TXT" & @CRLF & _
"qwarebatch2_ptres_20150602.TXT" & @CRLF & _
"qwarebatch_ra_20150602.TXT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")