#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<group>(?P<starttag><(?P<tagname>p)[^>]*>)(?P<data>.*)(?P<endtag><\/\3>))"
Local $sString = "<p>COVEMA</p>" & @CRLF & _
"<p>PALMERO</p>" & @CRLF & _
"<p>PLASTIFERRO</p>" & @CRLF & _
"<p>UOCRA</p>" & @CRLF & _
"<p>REPAS</p>" & @CRLF & _
"<p>BTU</p>" & @CRLF & _
"<p>PANEDILE</p>" & @CRLF & _
"<p>ELEPRINT</p>" & @CRLF & _
"<p>JOSÉ J. CHEDIACK</p>" & @CRLF & _
"<p>NIRO CONSTRUCCIONES</p>" & @CRLF & _
"<p>HELPORT</p>" & @CRLF & _
"<p>BISCAYNE</p>" & @CRLF & _
"<p>COARCO</p>" & @CRLF & _
"<p>ESUCO</p>" & @CRLF & _
"<p>CPC</p>" & @CRLF & _
"<p>TEL 3</p>" & @CRLF & _
"<p>CARTELLONE</p>" & @CRLF & _
"<p>MACRO</p>" & @CRLF & _
"<p>VIAL AGRO</p>" & @CRLF & _
"<p>ISOLUX CORSÁN</p>" & @CRLF & _
"<p>AFCP</p>" & @CRLF & _
"<p>FINNING</p>" & @CRLF & _
"<p>ROGGIO</p>" & @CRLF & _
"<p>ROVELLA CARRANZA</p>" & @CRLF & _
"<p>ACINDAR</p>" & @CRLF & _
"<p>IERIC</p>" & @CRLF & _
"<p>IGARRETA MÁQUINAS</p>" & @CRLF & _
"<p>RIVA</p>" & @CRLF & _
"<p>GRUPO ESTISOL</p>" & @CRLF & _
"<p>IECSA</p>" & @CRLF & _
"<p>ARMAFERRO</p>" & @CRLF & _
"<p>BRICONS</p>" & @CRLF & _
"<p>CNH INDUSTRIAL</p>" & @CRLF & _
"<p>PAOLINI</p>" & @CRLF & _
"<p>SERVIUR</p>" & @CRLF & _
"<p>SANDVIK</p>" & @CRLF & _
"<p>DECAVIAL</p>" & @CRLF & _
"<p>ODEBRECHT</p>" & @CRLF & _
"<p>ENAS</p>" & @CRLF & _
"<p>SITRA</p>" & @CRLF & _
"<p>SUPERCEMENTO</p>" & @CRLF & _
"<p>JCR</p>" & @CRLF & _
"<p>CONSTRUMEX</p>" & @CRLF & _
"<p>BRIALES</p>" & @CRLF & _
"<p>CAPUTO</p>" & @CRLF & _
"<p>LUCIANO</p>" & @CRLF & _
"<p>GALICIA</p>" & @CRLF & _
"<p>VICTOR CONTRERAS</p>" & @CRLF & _
"<p>SIKA ARGENTINA</p>" & @CRLF & _
"<p>CRIBA</p>" & @CRLF & _
"<p>BOETTO Y BUTTIGLIENGO</p>" & @CRLF & _
"<p>MILICIC</p>" & @CRLF & _
"<p>PERIODICO EL CONSTRUCTOR</p>" & @CRLF & _
"<p>PHONERENTAL</p>" & @CRLF & _
"<p>DOS ARROYOS</p>" & @CRLF & _
"<p>MARTINEZ Y DE LA FUENTE</p>" & @CRLF & _
"<p>AUSA</p>" & @CRLF & _
"<p>LUIS LOSI</p>" & @CRLF & _
"<p>AESA</p>" & @CRLF & _
"<p>CONSTRUCTORA SUDAMERICANA</p>" & @CRLF & _
"<p>PLANTEL</p>" & @CRLF & _
"<p>PCR</p>" & @CRLF & _
"<p>BANCO DE LA NACIÓN ARGENTINA</p>" & @CRLF & _
"<p>SUBTERRÁNEOS DE BUENOS AIRES</p>" & @CRLF & _
"<p>HOLA SIM</p>" & @CRLF & _
"<p>JOSÉ LUIS TRIVIÑO</p>" & @CRLF & _
"<p>TECHINT</p>" & @CRLF & _
"<p>EDUARDO COLOMBI</p>" & @CRLF & _
"<p>ALEMARSA</p>" & @CRLF & _
"<p>CENTRO CONSTRUCCIONES</p>" & @CRLF & _
"<p>TECNIPISOS</p>" & @CRLF & _
"<p>XAPOR</p>" & @CRLF & _
"<p>FONTANA NICASTRO</p>" & @CRLF & _
"<p>CONCRET-NOR</p>" & @CRLF & _
"<p>DYCASA</p>" & @CRLF & _
"<p>BURGWARDT</p>" & @CRLF & _
"<p>SULLAIR</p>" & @CRLF & _
"<p>FONDO FIDUCIARIO FEDERAL DE INFRAESTRUCTURA REGIONAL</p>" & @CRLF & _
"<p>FLOWTEX</p>" & @CRLF & _
"<p>PETERSEN THIELE Y CRUZ</p>" & @CRLF & _
"<p>LIHUÉ</p>" & @CRLF & _
"<p>IRAM</p>" & @CRLF & _
"<p>ESTUDIO YMAZ</p>" & @CRLF & _
"<p>VIDOGAR</p>" & @CRLF & _
"<p>BICE</p>" & @CRLF & _
"<p>ROMERO CAMMISA</p>" & @CRLF & _
"<p>BATIMAT</p>" & @CRLF & _
"<p>ALBA CAUCIÓN</p>" & @CRLF & _
"<p>PROBA</p>" & @CRLF & _
"<p>ICF</p>" & @CRLF & _
"<p>TECMA</p>" & @CRLF & _
"<p>ALESTE</p>" & @CRLF & _
"<p>DELEGACIÓN PROVINCIA DE BUENOS AIRES</p>" & @CRLF & _
"<p>HIDRAVIAL</p>" & @CRLF & _
"<p>BANCO CIUDAD</p>" & @CRLF & _
"<p>LAMANNA</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")