#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(public|)\s+(?<type>[^\s]+)\s+(?<name>[^\s]+)\s*\{(\s*(get|set)\s*;){2}\s*\}"
Local $sString = "public TypeName PropertyName { get; set; }"
Local $sSubst = "public static readonly DependencyProperty ${name}Property = DependencyProperty.Register("${name}", typeof(${type}), typeof(DependencyObjectType), new PropertyMetadata(default(${type}), ${name}Changed));\nprivate static void ${name}Changed(DependencyObject dependencyObject, DependencyPropertyChangedEventArgs dependencyPropertyChangedEventArgs)\n{\nvar dependencyObjectType = dependencyObject as DependencyObjectType;\nif(dependencyObjectType == null)\nreturn;\nvar oldValue = (${type})dependencyPropertyChangedEventArgs.OldValue;\nvar newValue = (${type})dependencyPropertyChangedEventArgs.NewValue;\n/* Logic... */\n}\n/// <summary>\n/// ${name}\n/// </summary>\npublic ${type} ${name}\n{\nget { return (${type})GetValue(${name}Property); }\nset { SetValue(${name}Property, value); }\n}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)