re = /(\d{4}\/\d{2}\/\d{2} \d{2}:\d{2}:\d{2})([\s\S])( Crafting plot )([0-9]{1,})( out of)|(Total plot creation time was )([0-9]{1,}\.[0-9]{1,})( sec)+/m
str = 'Search "(\\d{4}/\\d{2}/\\d{2} \\d{2}:\\d{2}:\\d{2})([\\s\\S])( Crafting plot )([0-9]{1,})( out of)|(Total plot creation time was )([0-9]{1,}\\.[0-9]{1,})( sec)+" (160 hits in 34 files of 35 searched)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210814_215818.log (2 hits)
Line 8: [2021/08/14 21:58:19] Crafting plot 1 out of 1
Line 59: [2021/08/15 05:44:30] Total plot creation time was 27971.1 sec (466.185 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210815_080836.log (2 hits)
Line 8: [2021/08/15 08:08:37] Crafting plot 1 out of 1
Line 59: [2021/08/15 16:01:17] Total plot creation time was 28359.8 sec (472.663 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210815_170107.log (4 hits)
Line 8: [2021/08/15 17:01:08] Crafting plot 1 out of 2
Line 59: [2021/08/16 00:58:04] Total plot creation time was 28616.2 sec (476.937 min)
Line 61: [2021/08/16 00:58:04] Crafting plot 2 out of 2
Line 113: [2021/08/16 10:07:55] Total plot creation time was 32990.6 sec (549.844 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210816_195304.log (4 hits)
Line 8: [2021/08/16 19:53:05] Crafting plot 1 out of 2
Line 59: [2021/08/17 03:30:48] Total plot creation time was 27462.9 sec (457.714 min)
Line 61: [2021/08/17 03:30:48] Crafting plot 2 out of 2
Line 113: [2021/08/17 12:22:15] Total plot creation time was 31887.6 sec (531.459 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210817_170604.log (7 hits)
Line 8: [2021/08/17 17:06:05] Crafting plot 1 out of 5
Line 59: [2021/08/17 22:52:41] Total plot creation time was 20796.2 sec (346.604 min)
Line 61: [2021/08/17 22:52:41] Crafting plot 2 out of 5
Line 113: [2021/08/18 05:12:56] Total plot creation time was 22815.2 sec (380.254 min)
Line 115: [2021/08/18 05:12:56] Crafting plot 3 out of 5
Line 167: [2021/08/18 11:43:12] Total plot creation time was 23415.4 sec (390.257 min)
Line 169: [2021/08/18 11:43:12] Crafting plot 4 out of 5
C:\\crypto\\madmax-plotter\\logs\\ploter_20210818_201935.log (1 hit)
Line 8: [2021/08/18 20:19:35] Crafting plot 1 out of 5
C:\\crypto\\madmax-plotter\\logs\\ploter_20210818_202319.log (9 hits)
Line 8: [2021/08/18 20:23:19] Crafting plot 1 out of 5
Line 59: [2021/08/19 02:07:23] Total plot creation time was 20643.5 sec (344.058 min)
Line 61: [2021/08/19 02:07:23] Crafting plot 2 out of 5
Line 113: [2021/08/19 08:30:26] Total plot creation time was 22983.1 sec (383.051 min)
Line 115: [2021/08/19 08:30:26] Crafting plot 3 out of 5
Line 167: [2021/08/19 15:01:34] Total plot creation time was 23467.9 sec (391.131 min)
Line 169: [2021/08/19 15:01:34] Crafting plot 4 out of 5
Line 223: [2021/08/19 21:34:30] Crafting plot 5 out of 5
Line 275: [2021/08/20 04:10:13] Total plot creation time was 23742.8 sec (395.713 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210820_075125.log (10 hits)
Line 8: [2021/08/20 07:51:26] Crafting plot 1 out of 5
Line 59: [2021/08/20 13:14:31] Total plot creation time was 19385.6 sec (323.094 min)
Line 61: [2021/08/20 13:14:31] Crafting plot 2 out of 5
Line 113: [2021/08/20 19:49:13] Total plot creation time was 23681.4 sec (394.69 min)
Line 115: [2021/08/20 19:49:13] Crafting plot 3 out of 5
Line 167: [2021/08/21 02:40:15] Total plot creation time was 24661.7 sec (411.028 min)
Line 169: [2021/08/21 02:40:15] Crafting plot 4 out of 5
Line 221: [2021/08/21 09:28:17] Total plot creation time was 24482.4 sec (408.041 min)
Line 223: [2021/08/21 09:28:17] Crafting plot 5 out of 5
Line 275: [2021/08/21 16:14:30] Total plot creation time was 24372.8 sec (406.213 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210821_163856.log (5 hits)
Line 8: [2021/08/21 16:38:57] Crafting plot 1 out of 3
Line 61: [2021/08/21 22:08:55] Crafting plot 2 out of 3
Line 113: [2021/08/22 04:45:29] Total plot creation time was 23793.6 sec (396.56 min)
Line 115: [2021/08/22 04:45:29] Crafting plot 3 out of 3
Line 167: [2021/08/22 11:38:12] Total plot creation time was 24763.1 sec (412.718 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210822_125334.log (10 hits)
Line 8: [2021/08/22 12:53:35] Crafting plot 1 out of 5
Line 59: [2021/08/22 18:33:01] Total plot creation time was 20365.5 sec (339.426 min)
Line 61: [2021/08/22 18:33:01] Crafting plot 2 out of 5
Line 113: [2021/08/23 01:02:41] Total plot creation time was 23380.2 sec (389.669 min)
Line 115: [2021/08/23 01:02:41] Crafting plot 3 out of 5
Line 167: [2021/08/23 07:46:55] Total plot creation time was 24254.3 sec (404.238 min)
Line 169: [2021/08/23 07:46:55] Crafting plot 4 out of 5
Line 221: [2021/08/23 14:33:55] Total plot creation time was 24419.7 sec (406.995 min)
Line 223: [2021/08/23 14:33:55] Crafting plot 5 out of 5
Line 275: [2021/08/23 21:25:15] Total plot creation time was 24680.1 sec (411.335 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210823_215042.log (4 hits)
Line 8: [2021/08/23 21:50:43] Crafting plot 1 out of 2
Line 59: [2021/08/24 03:32:59] Total plot creation time was 20535.9 sec (342.264 min)
Line 61: [2021/08/24 03:32:59] Crafting plot 2 out of 2
Line 113: [2021/08/24 10:12:40] Total plot creation time was 23980.9 sec (399.682 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210824_103118.log (2 hits)
Line 8: [2021/08/24 10:31:19] Crafting plot 1 out of 1
Line 59: [2021/08/24 16:10:01] Total plot creation time was 20322.3 sec (338.705 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210824_192912.log (1 hit)
Line 8: [2021/08/24 19:29:13] Crafting plot 1 out of 5
C:\\crypto\\madmax-plotter\\logs\\ploter_20210825_065842.log (1 hit)
Line 8: [2021/08/25 06:58:43] Crafting plot 1 out of 4
C:\\crypto\\madmax-plotter\\logs\\ploter_20210825_070602.log (3 hits)
Line 8: [2021/08/25 07:06:03] Crafting plot 1 out of 4
Line 59: [2021/08/25 11:13:14] Total plot creation time was 14830.5 sec (247.175 min)
Line 61: [2021/08/25 11:13:14] Crafting plot 2 out of 4
C:\\crypto\\madmax-plotter\\logs\\ploter_20210825_195602.log (5 hits)
Line 8: [2021/08/25 19:56:03] Crafting plot 1 out of 4
Line 59: [2021/08/26 00:39:34] Total plot creation time was 17011.1 sec (283.518 min)
Line 61: [2021/08/26 00:39:34] Crafting plot 2 out of 4
Line 113: [2021/08/26 05:55:01] Total plot creation time was 18926.6 sec (315.444 min)
Line 115: [2021/08/26 05:55:01] Crafting plot 3 out of 4
C:\\crypto\\madmax-plotter\\logs\\ploter_20210826_192325.log (6 hits)
Line 8: [2021/08/26 19:23:26] Crafting plot 1 out of 3
Line 59: [2021/08/27 00:03:25] Total plot creation time was 16798.4 sec (279.974 min)
Line 61: [2021/08/27 00:03:25] Crafting plot 2 out of 3
Line 113: [2021/08/27 05:18:52] Total plot creation time was 18926.7 sec (315.445 min)
Line 115: [2021/08/27 05:18:52] Crafting plot 3 out of 3
Line 167: [2021/08/27 10:40:15] Total plot creation time was 19283.7 sec (321.395 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210827_191654.log (24 hits)
Line 8: [2021/08/27 19:16:55] Crafting plot 1 out of 12
Line 59: [2021/08/27 23:49:48] Total plot creation time was 16372.9 sec (272.882 min)
Line 61: [2021/08/27 23:49:48] Crafting plot 2 out of 12
Line 113: [2021/08/28 05:02:26] Total plot creation time was 18757.4 sec (312.623 min)
Line 115: [2021/08/28 05:02:26] Crafting plot 3 out of 12
Line 167: [2021/08/28 10:25:31] Total plot creation time was 19385.2 sec (323.087 min)
Line 169: [2021/08/28 10:25:31] Crafting plot 4 out of 12
Line 221: [2021/08/28 15:41:21] Total plot creation time was 18950.1 sec (315.835 min)
Line 223: [2021/08/28 15:41:21] Crafting plot 5 out of 12
Line 275: [2021/08/28 21:03:05] Total plot creation time was 19303.4 sec (321.723 min)
Line 277: [2021/08/28 21:03:05] Crafting plot 6 out of 12
Line 329: [2021/08/29 02:33:41] Total plot creation time was 19836.5 sec (330.609 min)
Line 331: [2021/08/29 02:33:41] Crafting plot 7 out of 12
Line 383: [2021/08/29 08:11:10] Total plot creation time was 20248.5 sec (337.475 min)
Line 385: [2021/08/29 08:11:10] Crafting plot 8 out of 12
Line 437: [2021/08/29 13:54:20] Total plot creation time was 20589.9 sec (343.164 min)
Line 439: [2021/08/29 13:54:20] Crafting plot 9 out of 12
Line 491: [2021/08/29 19:43:06] Total plot creation time was 20925.8 sec (348.763 min)
Line 493: [2021/08/29 19:43:06] Crafting plot 10 out of 12
Line 545: [2021/08/30 01:33:24] Total plot creation time was 21018.6 sec (350.31 min)
Line 547: [2021/08/30 01:33:24] Crafting plot 11 out of 12
Line 599: [2021/08/30 07:09:25] Total plot creation time was 20161.1 sec (336.018 min)
Line 601: [2021/08/30 07:09:26] Crafting plot 12 out of 12
Line 653: [2021/08/30 12:32:45] Total plot creation time was 19399.8 sec (323.329 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210830_132951.log (19 hits)
Line 8: [2021/08/30 13:29:52] Crafting plot 1 out of 19
Line 59: [2021/08/30 18:08:31] Total plot creation time was 16718.3 sec (278.639 min)
Line 61: [2021/08/30 18:08:31] Crafting plot 2 out of 19
Line 113: [2021/08/30 23:29:36] Total plot creation time was 19265.2 sec (321.087 min)
Line 115: [2021/08/30 23:29:36] Crafting plot 3 out of 19
Line 167: [2021/08/31 04:55:44] Total plot creation time was 19567.8 sec (326.13 min)
Line 169: [2021/08/31 04:55:44] Crafting plot 4 out of 19
Line 221: [2021/08/31 10:26:51] Total plot creation time was 19867.6 sec (331.126 min)
Line 223: [2021/08/31 10:26:51] Crafting plot 5 out of 19
Line 275: [2021/08/31 15:55:57] Total plot creation time was 19745.8 sec (329.097 min)
Line 277: [2021/08/31 15:55:57] Crafting plot 6 out of 19
Line 329: [2021/08/31 21:31:45] Total plot creation time was 20147.4 sec (335.79 min)
Line 331: [2021/08/31 21:31:45] Crafting plot 7 out of 19
Line 383: [2021/09/01 03:09:05] Total plot creation time was 20239.9 sec (337.331 min)
Line 385: [2021/09/01 03:09:05] Crafting plot 8 out of 19
Line 437: [2021/09/01 08:42:33] Total plot creation time was 20008.7 sec (333.478 min)
Line 439: [2021/09/01 08:42:34] Crafting plot 9 out of 19
Line 491: [2021/09/01 14:24:04] Total plot creation time was 20490.3 sec (341.504 min)
Line 493: [2021/09/01 14:24:04] Crafting plot 10 out of 19
C:\\crypto\\madmax-plotter\\logs\\ploter_20210901_192805.log (3 hits)
Line 8: [2021/09/01 19:28:06] Crafting plot 1 out of 10
Line 59: [2021/09/02 05:23:04] Total plot creation time was 35698.2 sec (594.969 min)
Line 61: [2021/09/02 05:23:04] Crafting plot 2 out of 10
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_064600.log (1 hit)
Line 8: [2021/09/02 06:46:01] Crafting plot 1 out of 10
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_074518.log (1 hit)
Line 8: [2021/09/02 07:45:19] Crafting plot 1 out of 1
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_082604.log (1 hit)
Line 8: [2021/09/02 08:26:05] Crafting plot 1 out of 1
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_101102.log (1 hit)
Line 8: [2021/09/02 10:11:03] Crafting plot 1 out of 1
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_102847.log (1 hit)
Line 8: [2021/09/02 10:28:47] Crafting plot 1 out of 1
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_103626.log (1 hit)
Line 8: [2021/09/02 10:36:26] Crafting plot 1 out of 1
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_104425.log (1 hit)
Line 8: [2021/09/02 10:44:25] Crafting plot 1 out of 1
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_105521.log (1 hit)
Line 8: [2021/09/02 10:55:21] Crafting plot 1 out of 1
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_105730.log (2 hits)
Line 8: [2021/09/02 10:57:30] Crafting plot 1 out of 1
Line 59: [2021/09/02 17:41:48] Total plot creation time was 24257.6 sec (404.294 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210902_194626.log (6 hits)
Line 8: [2021/09/02 19:46:27] Crafting plot 1 out of 8
Line 59: [2021/09/02 23:41:53] Total plot creation time was 14126.2 sec (235.437 min)
Line 61: [2021/09/02 23:41:54] Crafting plot 2 out of 8
Line 113: [2021/09/03 04:10:59] Total plot creation time was 16145.6 sec (269.093 min)
Line 115: [2021/09/03 04:10:59] Crafting plot 3 out of 8
Line 169: [2021/09/03 08:47:55] Crafting plot 4 out of 8
C:\\crypto\\madmax-plotter\\logs\\ploter_20210903_162148.log (1 hit)
Line 8: [2021/09/03 16:21:48] Crafting plot 1 out of 5
C:\\crypto\\madmax-plotter\\logs\\ploter_20210903_162232.log (9 hits)
Line 8: [2021/09/03 16:22:32] Crafting plot 1 out of 5
Line 59: [2021/09/03 20:16:25] Total plot creation time was 14033.3 sec (233.889 min)
Line 61: [2021/09/03 20:16:25] Crafting plot 2 out of 5
Line 113: [2021/09/04 00:50:23] Total plot creation time was 16437.6 sec (273.96 min)
Line 115: [2021/09/04 00:50:23] Crafting plot 3 out of 5
Line 169: [2021/09/04 05:37:19] Crafting plot 4 out of 5
Line 221: [2021/09/04 10:29:36] Total plot creation time was 17536.8 sec (292.279 min)
Line 223: [2021/09/04 10:29:36] Crafting plot 5 out of 5
Line 275: [2021/09/04 15:23:39] Total plot creation time was 17643.1 sec (294.052 min)
C:\\crypto\\madmax-plotter\\logs\\ploter_20210904_180755.log (5 hits)
Line 8: [2021/09/04 18:07:56] Crafting plot 1 out of 5
Line 59: [2021/09/04 22:13:54] Total plot creation time was 14758.6 sec (245.976 min)
Line 61: [2021/09/04 22:13:54] Crafting plot 2 out of 5
Line 113: [2021/09/05 03:04:06] Total plot creation time was 17411.3 sec (290.188 min)
Line 115: [2021/09/05 03:04:06] Crafting plot 3 out of 5
C:\\crypto\\madmax-plotter\\logs\\ploter_20210905_160040.log (7 hits)
Line 8: [2021/09/05 16:00:40] Crafting plot 1 out of 10
Line 59: [2021/09/05 20:36:13] Total plot creation time was 16532.7 sec (275.544 min)
Line 61: [2021/09/05 20:36:13] Crafting plot 2 out of 10
Line 113: [2021/09/06 01:39:51] Total plot creation time was 18218.2 sec (303.637 min)
Line 115: [2021/09/06 01:39:51] Crafting plot 3 out of 10
Line 167: [2021/09/06 07:09:28] Total plot creation time was 19777.3 sec (329.622 min)
Line 169: [2021/09/06 07:09:28] Crafting plot 4 out of 10
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end