$re = '/^0[7-9]{1}[0-1]{1}[0-9]{8}$/m';
$str = '08123456787';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);