#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,2}([ -.\/])(\d{1,2}|[a-zA-z]{3,15})(?1)\d{2,4}( \d{2}:\d{2}(:\d{2}([.:]\d)?)?)?$|^(\d{1,2}|[a-zA-z]{3,15})([ -.\/])\d{1,2}(?7)\d{2,4}( \d{2}:\d{2}(:\d{2}([.:]\d)?)?)?$|^\d{2,4}([ -.\/])(\d{1,2}|[a-zA-z]{3,15})\d{1,2}(?11)( \d{2}:\d{2}(:\d{2}([.:]\d)?)?)?$"
Local $sString = "23/02/1993" & @CRLF & _
"23-02/1993" & @CRLF & _
"23-fev-1993" & @CRLF & _
"fev-23-1993" & @CRLF & _
"fev.02.93" & @CRLF & _
"28-OCT-90" & @CRLF & _
"28-OCT-1990" & @CRLF & _
"10/28/90" & @CRLF & _
"10/28/1990" & @CRLF & _
"28.10.90" & @CRLF & _
"dd.mm.yyyy" & @CRLF & _
"28.10.1990" & @CRLF & _
"90/10/28" & @CRLF & _
"yyyy/mm/dd" & @CRLF & _
"1990/10/28" & @CRLF & _
"4 Q 1990" & @CRLF & _
"OCT 90" & @CRLF & _
"OCT 1990" & @CRLF & _
"01:02" & @CRLF & _
"01:02:34.75" & @CRLF & _
"02:34" & @CRLF & _
"02:34.75" & @CRLF & _
"20 08:03" & @CRLF & _
"20 08:03:00" & @CRLF & _
"20-JUN-1990 08:03" & @CRLF & _
"20-JUN-1990 08:03:00" & @CRLF & _
"1990-06-20 08:03" & @CRLF & _
"1990-06-20 08:03:00.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")